【原创公式】:通达信做T利器分时主图指标公式

2022-07-20 0 1,059

【原创公式】:通达信做T利器分时主图指标公式

池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

ma30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
stICKLINE((MA30>强弱),MA30,强弱,0,-1),COLORLIGRAY;
STICKLINE((MA30<强弱),MA30,强弱,0,-1),COLORLICYAN;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLORLIMAGENTA,DOTLINE;
支撑:L1+P1*0.5/8,COLORCYAN,DOTLINE;
中:(支撑+阻力)/2,COLORLIGRAY,POINTDOT;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW,DOTLINE;
现价:CLOSE,COLORWHITE,LINETHICK3;
DRAWTEXT(ISLASTBAR AND 现价,现价,STRCAT(‘←’,CON2STR(现价,2))),COLORYELLOW;
STICKLINE(crOSS(支撑,现价),支撑,中,0,-1),COLORYELLOW;
STICKLINE(CROSS(现价,阻力),阻力,中,0,-1),COLORGREEN;
DRAWTEXT(LONGCROSS(支撑,现价,2),C*0.9982,’ 买’),COLORYELLOW;
DRAWTEXT(LONGCROSS(现价,阻力,2),C*1.0018,’ 卖’),COLORCYAN;
STICKLINE(C<支撑,支撑,C,1,0),COLORYELLOW;
DRAWICON(CROSS(支撑,现价),(支撑-中)/5+支撑,26);
STICKLINE(C>阻力,阻力,C,1,0),COLORLIGREEN;
DRAWICON(CROSS(现价,阻力),阻力-(支撑-中)/5,15);
DRAWTEXT(CURRBARSCOUNT=8,阻力+0.003,’顶’),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=8,支撑-0.003,’底’),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=8,(支撑+阻力)/2,’中’),COLORLIRED;
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=(A2+A3);
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
DD1:=1;
AAA1:=STRCAT(STRCAT(‘机构买’,CON2STR((100*A2)/A6,0)),’%’);
AAA2:=STRCAT(STRCAT(‘机构卖’,CON2STR((100*A3)/A6,0)),’%’);
AAA3:=STRCAT(STRCAT(‘机构总买入’,CON2STR((100*(A2-A3))/A6,0)),’%’);
A000:=DRAWTEXT_FIX(DD1=1,0,0.02,0,AAA1);
A001:=DRAWTEXT_FIX(DD1=1,0,0.13,0,AAA2);
DRAWTEXT_FIX(DD1=1,0.842,1,0,AAA3),COLORYELLOW;
现手买:BUYvol*DYNAINFO(7)*100/10000 COLOR0000FF,NODRAW;
现手卖:SELLVOL*DYNAINFO(7)*100/10000 COLOR00FF00,NODRAW;
合:=Abs(现手买)+ABS(现手卖)COLOR80FFFF,NODRAW;
差:=ABS(现手买)-ABS(现手卖)COLOR80FFFF,NODRAW;
MPB1:=ABS(现手买)/合*100;
MPB2:=ABS(现手卖)/合*100;
TESTSKIP(NOT(现手买 OR 现手卖 OR 合 OR 差 OR MPB1 OR MPB2)!=0);
DRAwrECTREL(595,1000,795,940,RGB(0,128,0));
DRAWRECTREL(595,995,795,945,RGB(0,148,0));
DRAWRECTREL(595,990,795,950,RGB(0,168,0));
DRAWRECTREL(595,985,795,955,RGB(0,188,0));
DRAWRECTREL(595,980,795,960,RGB(0,208,0));
DRAWRECTREL(595,975,795,965,RGB(0,228,0));
DRAWRECTREL(595,970,795,970,RGB(0,248,0));
DRAWRECTREL(595,1000,595+现手买*210/合,940,RGB(128,0,0));
DRAWRECTREL(595,995,595+现手买*210/合,945,RGB(148,0,0));
DRAWRECTREL(595,990,595+现手买*210/合,950,RGB(168,0,0));
DRAWRECTREL(595,985,595+现手买*210/合,955,RGB(188,0,0));
DRAWRECTREL(595,980,595+现手买*210/合,960,RGB(208,0,0));
DRAWRECTREL(595,975,595+现手买*210/合,965,RGB(228,0,0));
DRAWRECTREL(595,970,595+现手买*210/合,970,RGB(248,0,0));
DRAWRECTREL(595+现手买*210/合,940,595+现手买*210/合,1000,RGB(128,0,0));
DRAWRECTREL(795,940,795,1000,RGB(0,0.0,10));
DRAWRECTREL(594.8,939.8,594.8,1000,RGB(0,0,10));
DRAWRECTREL(594.8,939.8,594.8,939.8,RGB(0,0,10));
DRAWRECTREL(594.8,1000,594.8,1000,RGB(0,0,10));
DRAWTEXT_FIX(1,0.560,0.89,0,STRCAT(STRCAT(”,CON2STR(现手买,1)),’万’)),COLORRED;
DRAWTEXT_FIX(1,0.800,0.89,0,STRCAT(STRCAT(”,CON2STR(现手卖,1)),’万’)),COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)>0,0.678,0.888,0,STRCAT(‘ ‘,STRCAT(CON2STR(差,1),’万’))) COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)<0,0.678,0.888,0,STRCAT(' ',STRCAT(CON2STR(差,1),'万'))) COLORGREEN;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND(差)=0,0.678,0.888,0,STRCAT(‘ ‘,STRCAT(CON2STR(差,1),’万’))) COLOR80FFFF;
DRAWTEXT_FIX(1,0.800,0.98,0,STRCAT(STRCAT(‘ ‘,CON2STR(MPB2,1)),’%’)),COLORGREEN;
DRAWTEXT_FIX(1,0.560,0.98,0,STRCAT(STRCAT(”,CON2STR(MPB1,1)),’%’)),COLORRED;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【原创公式】:通达信做T利器分时主图指标公式 https://www.g3xs.com/51437.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视