【稳定公式】:通达信三红中线主图指标公式

2022-07-21 0 781

【稳定公式】:通达信三红中线主图指标公式

池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

{指标介绍:随着主图10日20日30日k线逐步变红,分步上车;反之,主图10日20日30日k线逐步变绿,分步下车。}

ma10:EMA(CLOSE,10),COLORGREEN;
MA20:EMA(CLOSE,20),COLORGREEN;
MA30:EMA(CLOSE,30),COLORGREEN;
IF(EMA(CLOSE,10)>=REF(EMA(CLOSE,10),1),EMA(CLOSE,10),DRAWNULL),COLORRED;
IF(EMA(CLOSE,20)>=REF(EMA(CLOSE,20),1),EMA(CLOSE,20),DRAWNULL),COLORRED;
IF(EMA(CLOSE,30)>=REF(EMA(CLOSE,30),1),EMA(CLOSE,30),DRAWNULL),COLORRED;
X_1:=EMA(CLOSE,30);
stICKLINE(CLOSE>=X_1 AND CLOSE>=OPEN,HIGH,LOW,0,1),COLOR0000AA;
STICKLINE(CLOSE>=X_1 AND CLOSE>=OPEN,OPEN,CLOSE,3,0),COLOR0000AA;
STICKLINE(CLOSE>=X_1 AND CLOSE>=OPEN,OPEN,CLOSE,2.3,0),COLOR0000CC;
STICKLINE(CLOSE>=X_1 AND CLOSE>=OPEN,OPEN,CLOSE,1.8,0),COLORRED;
STICKLINE(CLOSE>=X_1 AND CLOSE>=OPEN,OPEN,CLOSE,1,0),COLORCC66FF;
STICKLINE(CLOSE>=X_1 AND CLOSE<=OPEN,HIGH,LOW,0,1),COLOR0000AA;
STICKLINE(CLOSE>=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLOR0000AA;
STICKLINE(CLOSE>=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,2.3,0),COLOR0000CC;
STICKLINE(CLOSE>=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,1.8,0),COLORRED;
STICKLINE(CLOSE>=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,1,0),COLORCC66FF;
STICKLINE(CLOSE=OPEN,HIGH,LOW,0,1),COLORFF6600;
STICKLINE(CLOSE=OPEN,OPEN,CLOSE,3,0),COLORFF6600;
STICKLINE(CLOSE=OPEN,OPEN,CLOSE,2.3,0),COLORFF9900;
STICKLINE(CLOSE=OPEN,OPEN,CLOSE,1.8,0),COLORFFCC00;
STICKLINE(CLOSE=OPEN,OPEN,CLOSE,1,0),COLORCYAN;
STICKLINE(CLOSE<=X_1 AND CLOSE<=OPEN,HIGH,LOW,0,0),COLORFF6600;
STICKLINE(CLOSE<=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,3,0),COLORFF6600;
STICKLINE(CLOSE<=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,2.3,0),COLORFF9900;
STICKLINE(CLOSE<=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,1.8,0),COLORFFCC00;
STICKLINE(CLOSE<=X_1 AND CLOSE<=OPEN,OPEN,CLOSE,1,0),COLORCYAN;
X_2:=REF(HIGH,8)=HHV(HIGH,2*8+1);
X_3:=FILTER(X_2,8);
X_4:=BacKSET(X_3,8+1);
X_5:=FILTER(X_4,8);
X_6:=BACKSET(ISLASTBAR,BArslAST(X_5)+1);
X_7:=X_6>REF(X_6,1);
DRAWLINE(X_5,HIGH,X_7,HIGH,1),COLORBLACK,LINETHICK2;
X_8:=REF(LOW,8)=LLV(LOW,2*8+1);
X_9:=FILTER(X_8,8);
X_10:=BACKSET(X_9,8+1);
X_11:=FILTER(X_10,8);
X_12:=BACKSET(ISLASTBAR,BARSLAST(X_11)+1);
X_13:=X_12>REF(X_12,1);
DRAWLINE(X_11,LOW,X_13,LOW,1),COLORBLACK,LINETHICK2;
X_14:=INTPART(3*8/5);
X_15:=REF(HIGH,X_14)=HHV(HIGH,2*X_14+1);
X_16:=FILTER(X_15,X_14);
X_17:=BACKSET(X_16,X_14+1);
X_18:=IF(REF(CLOSE,1)*1.1-CLOSE<0.01,1,0);
STICKLINE(X_18,OPEN,CLOSE,3.5,0),COLOR871F78;
STICKLINE(X_18,OPEN,CLOSE,2.3,0),COLORYELLOW;
STICKLINE(X_18,HIGH,LOW,0,0),COLORYELLOW;
X_19:=STRCAT(1,STRCAT(STRCAT(STRCAT(2,HYBLOCK),STRCAT(3,DYBLOCK)),STRCAT(4,GNBLOCK)));
X_20:=STRCAT(STRCAT(5,CON2STR(TOTALCAPITAL/1000000,2)),6);
X_21:=STRCAT(STRCAT(7,CON2STR(CAPITAL/1000000,2)),6);
X_22:=STRCAT(STRCAT(8,CON2STR(CAPITAL/TOTALCAPITAL*100,2)),9);
X_23:=STRCAT(STRCAT(10,CON2STR(CAPITAL/1000000*CLOSE,2)),6);
X_24:=STRCAT(11,STRCAT(STRCAT(STRCAT(X_20,X_21),X_22),X_23));
X_25:=STRCAT(12,CON2STR(CLOSE/FINANCE(33),2));
X_26:=STRCAT(13,CON2STR(CLOSE/(FINANCE(20)/FINANCE(1)),2));
X_27:=STRCAT(14,CON2STR(CLOSE/FINANCE(34),2));
X_28:=STRCAT(15,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
X_29:=STRCAT(16,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
X_30:=STRCAT(17,CON2STR(FINANCE(30)/FINANCE(20)*100,2));
X_31:=STRCAT(18,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
X_32:=STRCAT(19,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(X_25,X_26),X_27),X_28),X_29),X_30),X_31));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,X_19),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.09,0,X_24),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.16,0,X_32),COLORYELLOW;
X_33:=FINANCE(25)/FINANCE(15);
X_34:=FINANCE(44);
X_35:=FINANCE(43);
X_36:=CONST(FINANCE(38));
X_37:=CONST(FINANCE(34));
X_38:=CONST(FINANCE(25)/FINANCE(1));
X_39:=CONST(FINANCE(32));
X_40:=CONST(FINANCE(18));
X_41:=ROUND(FINANCE(40)/100000000);
X_42:=FINANCE(7)/100000000;
X_43:=DYNAINFO(51);
X_44:=DYNAINFO(17);
X_45:=DYNAINFO(40);
X_46:=ISBUYORDER;
X_47:=DYNAINFO(39)/FINANCE(43);
X_48:=DYNAINFO(7);
X_49:=DYNAINFO(13)*100;
X_50:=COSTEX(CLOSE,REF(CLOSE,BARSCOUNT(CLOSE)-1));
X_51:=DYNAINFO(3);
X_52:=DYNAINFO(4);
X_53:=X_28>3;
X_54:=X_28>0.01 AND X_28<=3;
X_55:=X_31>2;
X_56:=X_31>0;
X_57:=X_34>1;
X_58:=X_34>0;
X_59:=X_35>2;
X_60:=X_35>0.2;
X_61:=X_36>0.01;
X_62:=X_36>0.001;
X_63:=X_37>2;
X_64:=X_37>0.01;
X_65:=X_39>0.5;
X_66:=X_39>0.001;
X_67:=X_40>0.5;
X_68:=X_40>0.002;
X_69:=X_53 AND X_55 AND X_57 AND X_59 AND X_61 AND X_63 AND X_65 AND X_67;
X_70:=X_54 AND X_56 AND X_58 AND X_60 AND X_62 AND X_64 AND X_66 AND X_68;
DRAWTEXT_FIX(X_69 AND X_70=0,0.62,0.05,0,20),COLORRED;
DRAWTEXT_FIX(X_70,0.62,0.05,0,21),COLORMAGENTA;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【稳定公式】:通达信三红中线主图指标公式 https://www.g3xs.com/51431.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视