【稳定公式】:通达信超强K线主图指标公式

2016-09-21 0 273

【稳定公式】:通达信超强K线主图指标公式

池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

三一:H-(H-L)*0.333,NODRAW;
二一:H-(H-L)*0.5,NODRAW;
三二:H-(H-L)*0.666,NODRAW;
实体三一:O+(C-O)*0.666,NODRAW;
实体腰线:O+(C-O)*0.5,NODRAW;
{多彩k线-主图公式, 显示大阳\\大阴\\涨停\\跌停\\假阴\\假阳\\跳空\\大K线中点,适用于通达信 }
DRAWTEXT_FIX(ISLAstBAR,0,0,0,HYBLOCK);{在屏幕左上角显示所属行业板块}
DRAWTEXT_FIX(ISLASTBAR,0.05,0,0,DYBLOCK);{在屏幕左上角显示所属地域板块}
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,GNBLOCK);{在屏幕左上角显示所属概念板块}
{跳空}
STICKLINE(REF(L,1)>H,H,REF(L,1),5,0),COLORGRAY;
STICKLINE(REF(H,1)<L,L,REF(H,1),5,0),COLORGRAY;
C_: CONST(C),COLORLIRED,POINTDOT;{现价线}
ma5:=MA(C,5);
MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;
DRAWKLINE(H,O,L,C);{重绘K线}
RC1:=REF(C,1);
CS:=IF(C>=1,10000,100000);
C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}
C涨停5 :=1.05*RC1-49/CS;
C跌停10:=0.90*RC1+51/CS;
C跌停5 :=0.95*RC1+51/CS;
ST:=NAMELIKE(‘S’) OR NAMELIKE(‘*S’);
涨停:= IF(ST, C>=C涨停5, C>=C涨停10);
跌停:= IF(ST, C<=C跌停5, C<=C跌停10);
盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);
盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);
STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}
STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}
大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);
STICKLINE(大阳线,O,C,1,0),COLOR0000BB;
大阴线:=C<O AND (C<=C跌停5 OR C1000 AND C<RC1*0.976);
STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;
STICKLINE(涨停,O,C,1,0),COLORMAGENTA;
STICKLINE(跌停,O,C,1,0),COLORLICYAN;
假阴:=CREF(C,1);
STICKLINE(假阴,O,C,0,0),COLORRED;{假阴柱};
假阳:=C>O AND C<REF(C,1);
STICKLINE(假阳,O,C,0,0),COLORGREEN;{假阳柱};
大盘TJ:=PERIOD=5 AND NAMELIKE(‘上证指数’)
AND (Abs((C-REF(C,1)))/REF(C,1)>=0.025 OR ABS(C-O)>=60);
STICKLINE(大盘TJ,(H+L)/2,(H+L)/2,2,0),COLORYELLOW;{显示大盘日线的60点大K线中值};
STICKLINE((大阳线 OR 大阴线 OR 涨停 OR 跌停)
AND BETWEEN(C,1,500),L+(H-L)/2,L+(H-L)/2,1,0),COLORYELLOW;{大K线画中点线};

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【稳定公式】:通达信超强K线主图指标公式 https://www.g3xs.com/15483.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视