【好用的公式】:通达信改进型分水岭主图指标公式

2016-09-27 0 540

【好用的公式】:通达信改进型分水岭主图指标公式

池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

{板块}
所属板块:=stRCAT(‘【所属板块】’,STRCAT(STRCAT(STRCAT(‘【行业】’,HYBLOCK),STRCAT(‘【地域】’,DYBLOCK)),STRCAT(‘【概念】’,GNBLOCK)));
{业绩综合}
市盈率:=STRCAT(‘【市盈率】’,CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(‘【市销率】’,CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(‘【市净率】’,CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(‘【净资收益率】’,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(‘【毛利率】’,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(‘【净利润率】’,CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(‘【主营利润率】’,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
未分利润:=STRCAT(STRCAT(‘【未分利润】’,CON2STR(FINANCE(32)/1,2)),’元/股’);
公积金:=STRCAT(STRCAT(‘【公积金】’,CON2STR(FINANCE(18)/1,2)),’元/股’);
当前业绩:=STRCAT(‘【当前业绩】’,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市销率,市净率),净资收益率),毛利率),净利润率),主营利润率),未分利润),公积金));
{财务分折}
现金流:=STRCAT(STRCAT(‘【现金流】’,CON2STR(FINANCE(25)/100000000,2)),’亿’);
流动比率:=STRCAT(‘【流动比率】’,CON2STR(FINANCE(11)/FINANCE(15),2));
速动比率:=STRCAT(‘【速动比率】’,CON2STR((FINANCE(11)-FINANCE(27))/FINANCE(15),2));
XA1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
XA2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
XA3:=FINANCE(23)/FINANCE(10)*3.3;
XA4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
XA5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=XA1+XA2+XA3+XA4+XA5;
预警:=IF(Z值=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT(‘【财务预警】’,STRCAT(预警,STRCAT(‘-Z值: ‘,CON2STR(Z值,2))));
优质资产率:=STRCAT(‘【优质资产率】’,CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(‘【现金负债比】’,CON2STR(FINANCE(25)/FINANCE(15),2));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
流动债:=STRCAT(STRCAT(‘【流动债】’,CON2STR(FINANCE(15)/100000000,2)),’亿’);
长期债:=STRCAT(STRCAT(‘【长期债】’,CON2STR(FINANCE(16)/100000000,2)),’亿’);
财务分析:=STRCAT(‘【财务分析】’,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(现金流,流动比率),速动比率),现金负债比),优质资产率),财务预警),流动债),长期债));
{盘面分析}
平均成本:=STRCAT(‘【平均成本】’,CON2STR(COST(50),2));
主力成本:=STRCAT(‘【主力成本】’,CON2STR(COST(4),2));
重心:=STRCAT(‘【重心】’,CON2STR((H+L+C)/3,2));
压力Ⅰ:=STRCAT(‘【压力Ⅰ】’,CON2STR(2*(H+L+C)/3-LOW,2));
支撑Ⅰ:=STRCAT(‘【支撑Ⅰ】’,CON2STR(2*(H+L+C)/3-HIGH,2));
压力Ⅱ:=STRCAT(‘【压力Ⅱ】’,CON2STR((H+L+C)/3+(REF(HIGH,1)-REF(LOW,1)),2));
支撑Ⅱ:=STRCAT(‘【支撑Ⅱ】’,CON2STR((H+L+C)/3-(REF(HIGH,1)-REF(LOW,1)),2));
套牢盘%:=STRCAT(‘【套牢盘%】’,CON2STR((1-WINNER(C))*100,2));
获利盘%:=STRCAT(‘【获利盘%】’,CON2STR(100*WINNER(C),2));
筹码分析:=STRCAT(‘【筹码分析】’,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(平均成本,主力成本),重心),压力Ⅰ),支撑Ⅰ),压力Ⅱ),支撑Ⅱ),套牢盘%),获利盘%));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,所属板块),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,财务分析),COLORFFFFBF;DRAWTEXT_FIX(ISLASTBAR,0.00,0.18,0,当前业绩),COLORFFFFBF;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.24,0,筹码分析),COLORFF99FF;
山还是山:SMA(C,125,1),COLORYELLOW;
B1:=ma(C,1);
B2:SMA(SMA(SMA(B1,2,1),2,1),2,1),COLORRED;
SMA2:MA(B2,2),COLORCYAN;
箱顶:HHV(MA(B2,2),58),COLOR00AAFF;
IF(B2<SMA2,SMA2,DRAWNULL),COLORFFA93F,LINETHICK2;
10:=EMA(CLOSE,10);
25:EMA(CLOSE,25),COLORWHITE;
40:EMA(CLOSE,40),COLOR00AA00;
80:EMA(CLOSE,80),COLORFFFF00;
125:SMA(C,125,1),COLORYELLOW;
VAR1:=(100 – ((90 * (HHV(HIGH,21) – CLOSE)) / (HHV(HIGH,21) – LLV(LOW,21))));
VAR3:=(100 – MA(((100 * (HHV(HIGH,6) – CLOSE)) / (HHV(HIGH,6) – LLV(LOW,6))),34));
分水岭:SMA(MA(C,5),430,1),COLORB48F33,LINETHICK2;
买:DRAWTEXT(crOSS(VAR1,MA(VAR3,VAR1)) AND B2>SMA2,(LOW * 0.97),’←⊙买’),COLORRED;
DRAWTEXT(CROSS(C,10) AND VAR3>1 AND B2>SMA2,L*0.99,’←※’),COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(C,25) AND VAR3>1 AND B2>SMA2,L*0.99,’←◇’),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(C,40) AND VAR3>1 AND B2>SMA2,L*0.99,’←□’),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(C,80) AND VAR3>1 AND B2>SMA2,L*0.99,’←○’),COLORCCFF66,LINETHICK2;
DRAWTEXT(CROSS(C,125) AND VAR1>1,L*0.99,’←△’),COLORYELLOW,LINETHICK2;
{牛熊界:MA(CLOSE,49),LINETHICK2,COLORGRAY;};
{.财务板块}
DRAWTEXT_FIX(1,0.65,0.018,0,’市盈率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.7,0.018,0,CONST(DYNAINFO(39))),COLORYELLOW;
DRAWTEXT_FIX(1,0.76,0.02,0,’市净率:’),COLOR0080FF;
DRAWNUMBER_FIX(1,0.81,0.02,0,CONST(C/FINANCE(34))),COLOR0080FF;
DRAWTEXT_FIX(1,0.86,0.018,0,’每股收益(元):’),COLORFF00FF;
DRAWNUMBER_FIX(1,0.95,0.018,0,CONST(FINANCE(33))),COLORFF00FF;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【好用的公式】:通达信改进型分水岭主图指标公式 https://www.g3xs.com/15455.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视