【简单明了公式】:通达信民间自动画线主图指标公式

2016-10-24 0 356

【简单明了公式】:通达信民间自动画线主图指标公式

池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
stICKLINE(涨停,O,C,1,0),COLORYELLOW;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),COLORBLUE;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(maX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(Abs(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=zig(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR100:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));
VAR200:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));
VAR300:=(100 – MA(((100 * (HHV(HIGH,5) – CLOSE)) / (HHV(HIGH,5) – LLV(LOW,5))),34));
F:IF(crOSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
{价:}
{JC1:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;
参考价1:SMA(JC1,5,1),CIRCLEDOT,COLORGREEN;
IF(C>=参考价1,参考价1,DRAWNULL),CIRCLEDOT,COLOR0000FF;}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
警告灯:IF(TJ,HIGH*1.008,DRAWNULL),CROSSDOT,LINETHICK2,COLORCYAN;
PL:=BArslAST(TJ);
支撑:IF(BARSLAST(TJ1),
REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压力:IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
TJ_2:=LOW>REF(REF(LOW,TS),PL);
DRAWTEXT(ISLASTBAR,压力,’压力’),COLORYELLOW;
DRAWTEXT(ISLASTBAR,支撑,’支撑’),COLOREA91B5;
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BacKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;
ZGSTAR:=(高点压力+低点支撑)/2;
ZGEND:=CONST((高点压力+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
VAR1:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSEREF(CLOSE,1),88,0)>0, 91, 0);
STICKLINE(VAR1>90,L,L*0.92,0.1,0),COLORRED;
DRAWTEXT(VAR1>90,LOW*0.92,’B’),COLORRED;
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B11:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK4,COLORRED;
S11:IF(CROSS(80,rsi)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK4,COLORGREEN;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK4,COLORGREEN;
A1:=BARSLAST(REF(CROSS(“macd.DIF”,”MACD.DEA”),1));
B1:=REF(C,A1+1)> C AND REF(“MACD.DIF”,A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1> 0,L-0.02,’M底’),COLOR00FFFF;{MACD底背离}
A2:=BARSLAST(REF(CROSS(“kdj.K”,”kdJ.D”),1));
B2:=REF(C,A2+1)> C AND REF(“KDJ.K”,A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,L-0.10,’K底’),COLORFF00FF;{KDJ底背离}
A3:=BARSLAST(REF(CROSS(“RSI.RSI1″,”RSI.RSI2”),1));
B3:=REF(C,A3+1)> C AND REF(“RSI.RSI1”,A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3> 0,L-0.18,’R底’),COLOR0000FF;{RSI底背离}
C1:=BARSLAST(REF(CROSS(“MACD.DEA”,”MACD.DIF”),1));
D1:=REF(C,C1+1) “MACD.DIF” AND CROSS(“MACD.DEA”,”MACD.DIF”);
DRAWTEXT(D1> 0,H+0.16,’M顶’),COLOR00FF00;{MACD顶背离}
C2:=BARSLAST(REF(CROSS(“KDJ.D”,”KDJ.K”),1));
D2:=REF(C,C2+1) “KDJ.K” AND CROSS(“KDJ.D”,”KDJ.K”);
DRAWTEXT(D2> 0,H+0.08,’K顶’),COLORFFFFCC;{KDJ顶背离}
C3:=BARSLAST(REF(CROSS(“RSI.RSI2″,”RSI.RSI1”),1));
D3:=REF(C,C3+1) “RSI.RSI1” AND CROSS(“RSI.RSI2″,”RSI.RSI1”);
DRAWTEXT(D3> 0,H+0.04,’R顶’),COLORFF9900;{RSI顶背离};
下降通道:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1);

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【简单明了公式】:通达信民间自动画线主图指标公式 https://www.g3xs.com/15340.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视