【原创公式】:通达信MACD画框主图指标公式

2017-10-03 0 918

【原创公式】:通达信MACD画框主图指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

M:=macd.MacD;
JT:=BArslAst(crOSS(M,0));
ST:=BARSLAST(CROSS(0,M));
Q1:=BACKSET(ST=0,2);
QT:=BARSLAST(CROSS(Q1=1,0.5));
QQT:=BACKSET(QT=0,JT+1);
QT2:=BARSLAST(CROSS(Q1=1,0.5));
HH:=HHV(H,JT+1);
LL:=LLV(L,JT+1);
XJH:=REFX(HH,BARSNEXT(QT2=0));
XJL:=REFX(LL,BARSNEXT(QT2=0));
SQ1:=BACKSET(JT=0,2);
SQT:=BARSLAST(CROSS(SQ1=1,0.5));
SQQT:=BACKSET(SQT=0,ST+1);
SQT2:=BARSLAST(CROSS(SQ1=1,0.5));
SHH:=HHV(H,ST+1);
SLL:=LLV(L,ST+1);
XSH:=REFX(SHH,BARSNEXT(SQT2=0));
XSL:=REFX(SLL,BARSNEXT(SQT2=0));
TJ1:=CONST(M)>0 AND CURRBARSCOUNT=CONST(JT)+1;
TJ2:=CONST(M)<0 AND CURRBARSCOUNT=CONST(ST)+1;
STICKLINE(QQT=1 AND M>0,XJH,XJH,4,-1),COLORmaGENTA;
STICKLINE(QQT=1 AND M>0,XJL,XJL,4,-1),COLORMAGENTA;
STICKLINE(JT=0,XJH,XJL,0,-1),COLORMAGENTA;
STICKLINE(QT2=0 AND ST>0,HH,LL,0,-1),COLORMAGENTA;
DRAWLINE(TJ1,CONST(HH),ISLASTBAR AND CONST(M)>0,HH,0),COLORMAGENTA,DOTLINE;
DRAWLINE(TJ1,CONST(LL),ISLASTBAR AND CONST(M)>0,LL,0),COLORMAGENTA,DOTLINE;
STICKLINE(CONST(M)>0 AND CURRBARSCOUNT=CONST(JT)+1,CONST(HH),CONST(LL),0,-1),COLORMAGENTA;
STICKLINE(CONST(M)>0 AND ISLASTBAR AND CONST(ST)>0,CONST(HH),CONST(LL),0,-1),COLORMAGENTA;
STICKLINE(SQQT=1 AND M<0,XSH,XSH,4,-1),COLORGREEN;
STICKLINE(SQQT=1 AND M<0,XSL,XSL,4,-1),COLORGREEN;
STICKLINE(ST=0,XSH,XSL,0,-1),COLORGREEN;
STICKLINE(SQT2=0,SHH,SLL,0,-1),COLORGREEN;
DRAWLINE(TJ2,CONST(SHH),ISLASTBAR AND CONST(M)<0,SHH,0),COLORGREEN,DOTLINE;
DRAWLINE(TJ2,CONST(SLL),ISLASTBAR AND CONST(M)<0,SLL,0),COLORGREEN,DOTLINE;
STICKLINE(CONST(M)<0 AND CURRBARSCOUNT=CONST(ST)+1,CONST(SHH),CONST(SLL),0,-1),COLORGREEN;
STICKLINE(CONST(M)0,CONST(SHH),CONST(SLL),0,-1),COLORGREEN;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【原创公式】:通达信MACD画框主图指标公式 https://www.g3xs.com/14011.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视