【抓行情公式】:通达信特殊MACD指标公式

2017-10-13 0 655

【抓行情公式】:通达信特殊MACD指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

DIF:Ema(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MYY:=EMA(CLOSE,3)-EMA(CLOSE,3);
YMM:=EMA(MYY,3);
macd:(DIF-DEA)*2,COLORstICK;
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;
MacD2:=MACD;
获利比:WINNER(C),NODRAW;
STICKLINE((MACD2>=0),0,MACD2,0,1),COLORRED;
STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,0,0),COLORMAGENTA;
STICKLINE((MACD2<0),0,MACD2,0,0),COLORGREEN;
STICKLINE(((MACD2 REF(MACD2,1))),0,MACD2,0,1),COLORWHITE;
DRAWICON(LONGcrOSS(CLOSE,MA(CLOSE,5),17),MACD2,1);
DRAWICON(LONGCROSS(MA(CLOSE,5),CLOSE,17),MACD2,2);
DRAWICON(CROSS(DIF,DEA) AND DIF<=0.2,LLV(DIF,1),29);
DRAWICON(CROSS(DIF>=0,DIF<DEA),DIF,1);
低位反转:=MACDREF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)AND REF(MACD ,2)<REF(MACD ,3)AND REF(MACD ,3)<REF(MACD ,4);
STICKLINE(低位反转,0,MACD,0.3,0),COLORRED;
高位反转:=MACD>0 AND MACDREF(MACD ,2)AND REF(MACD ,2)>REF(MACD ,3)AND REF(MACD ,3)>REF(MACD ,4);
STICKLINE(高位反转,0,MACD,0.3,0),COLORGREEN;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BArslAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,0,25);
三次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;
DRAWICON(三次金叉,0,26);A1:=IF(MACD2>0,1,-1);
TJ:=MACD2>0;
T:=MACD2<0;
DRAWTEXT(BARSLAST(TJ)=1,MACD2,’1′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=2,MACD2,’2′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=3,MACD2,’3′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=5,MACD2,’5′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,MACD2,’8′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,MACD2,’13’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,MACD2,’21’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,MACD2,’34’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,MACD2,’55’),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=1,MACD2,’1′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=2,MACD2,’2′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=3,MACD2,’3′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=5,MACD2,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,MACD2,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,MACD2,’13’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,MACD2,’21’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,MACD2,’34’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,MACD2,’55’),COLORGREEN;
涨家数:INDEXADV,NODRAW,COLORRED;
跌家数:INDEXDEC,NODRAW,COLORGREEN;
正量能:涨家数/(涨家数+跌家数)*100,NODRAW,COLORMAGENTA;
负量能:跌家数/(涨家数+跌家数)*100,NODRAW,COLORYELLOW;
高开:=O>REF(H,1);
隔空高开:高开,NODRAW;
低开:=O<REF(L,1);
隔空低开:低开,NODRAW;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【抓行情公式】:通达信特殊MACD指标公式 https://www.g3xs.com/13980.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视