【易用公式】:通达信均线数浪及三角形主图指标公式

2017-12-07 0 1,014

【易用公式】:通达信均线数浪及三角形主图指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

X:=30;
D:=60;
M5:=Ema(C,X);
M10:=EMA(C,D);
T:=BArslAst(crOSS(M5,M10));
ST:=BARSLAST(CROSS(M10,M5));
T1:=SUMBARS(T=0,2);
T2:=SUMBARS(T=0,3);
ST1:=SUMBARS(ST=0,2);
ST2:=SUMBARS(ST=0,3);
H1:=IF(CONST(M5)>CONST(M10),HHV(H,T+1),REF(HHV(H,T+1),ST));
L1:=IF(CONST(M5)<CONST(M10),LLV(L,ST+1),REF(LLV(L,ST+1),T));
H2:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST),REF(HHV(H,T+1),ST1-1));
L2:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T),REF(LLV(L,ST+1),T1-1));
H3:=IF(CONST(M5)>CONST(M10),REF(HHV(H,T+1),ST1-1),REF(HHV(H,T+1),ST2-1));
L3:=IF(CONST(M5)<CONST(M10),REF(LLV(L,ST+1),T1-1),REF(LLV(L,ST+1),T2-1));
TJ1:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T2) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ2:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST1) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ3:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T1) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ4:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(ST) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ5:=CONST(M5)>CONST(M10) AND CURRBARSCOUNT>=CONST(T)+1 AND CURRBARSCOUNT<=CONST(ST)+1 AND L=CONST(L1);
TJ6:=CONST(M5)>CONST(M10) AND H=CONST(H1) AND CURRBARSCOUNT<=CONST(ST2);
TJ7:=CONST(M5)=CONST(ST2) AND CURRBARSCOUNT<=CONST(T2) AND H=CONST(H3);
TJ8:=CONST(M5)=CONST(T1) AND CURRBARSCOUNT<=CONST(ST2) AND L=CONST(L3);
TJ9:=CONST(M5)=CONST(ST1) AND CURRBARSCOUNT<=CONST(T1) AND H=CONST(H2);
TJ10:=CONST(M5)=CONST(T) AND CURRBARSCOUNT<=CONST(ST1) AND L=CONST(L2);
TJ11:=CONST(M5)=CONST(ST)+1 AND CURRBARSCOUNT<=CONST(T)+1 AND H=CONST(H1);
TJ12:=CONST(M5)<CONST(M10) AND L=CONST(L1)AND CURRBARSCOUNT<=CONST(T2);
DRAWLINE(TJ1,L,TJ2,H,0),COLORMAGENTA;
DRAWLINE(TJ2,H,TJ3,L,0),COLORMAGENTA;
DRAWLINE(TJ3,L,TJ4,H,0),COLORMAGENTA;
DRAWLINE(TJ4,H,TJ5,L,0),COLORMAGENTA;
DRAWLINE(TJ5,L,TJ6,H,0),COLORMAGENTA;
DRAWLINE(TJ7,H,TJ8,L,0),COLORGREEN;
DRAWLINE(TJ8,L,TJ9,H,0),COLORGREEN;
DRAWLINE(TJ9,H,TJ10,L,0),COLORGREEN;
DRAWLINE(TJ10,L,TJ11,H,0),COLORGREEN;
DRAWLINE(TJ11,H,TJ12,L,0),COLORGREEN;
HH:=CONST(MAX(MAX(H1,H2),H3));
LL:=CONST(MIN(MIN(L1,L2),L3));
Z:=(HH-LL)/2+LL;
DRAWLINE(TJ7,Z,ISLASTBAR,Z,0),COLORGREEN,DOTLINE;
DRAWTEXT(TJ7,CONST(Z)*1.01,VARCAT(VARCAT(‘中区价位:’,VAR2STR(CONST(Z),2)),’元’)),COLORGREEN;
HH1:=CONST(MAX(H1,MAX(H2,H3)));
LL1:=CONST(MIN(MIN(L1,L2),L3));
Z1:=(HH1-LL1)/2+LL1;
DRAWLINE(TJ1,Z1,ISLASTBAR,Z1,0),COLORMAGENTA,DOTLINE;
DRAWTEXT(TJ1,CONST(Z)*1.01,VARCAT(VARCAT(‘中区价位:’,VAR2STR(CONST(Z1),2)),’元’)),COLORMAGENTA;
LT:=BARSLAST(L=LLV(L,120));
CT:=CONST(LT)+1;
HT:=FINDHIGHBARS(H,CT,CT,1);
{HH:=FINDHIGH(H,CT,CT,1);
LL:=CONST(REF(L,LT));}
QD:=CURRBARSCOUNT=CT*2;
ZD:=CURRBARSCOUNT=CT;
DRAWLINE(QD,CONST(HH),ISLASTBAR,CONST(HH),0),COLORYELLOW;
DRAWLINE(QD,CONST(HH),ZD,LL,0),COLORYELLOW;
DRAWLINE(ZD,LL,ISLASTBAR,CONST(HH),0),COLORYELLOW;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【易用公式】:通达信均线数浪及三角形主图指标公式 https://www.g3xs.com/13810.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视