【股先知公式】:通达信MACD长短牛熊指标公式

2017-12-13 0 693

【股先知公式】:通达信MACD长短牛熊指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

DIF:=Ema(CLOSE,12)-EMA(CLOSE,24);
DEA:=EMA(DIF,2);
macd:=(DIF-DEA)*2,COLORstICK;
DIFD:=MacD.DIF#DAY;
DEAD:=MACD.DEA#DAY;
MACDD:=MACD.MACD#DAY;
DIFW:=MACD.DIF#WEEK;
DEAW:=MACD.DEA#WEEK;
MACDW:=MACD.MACD#WEEK;
DIFM:=MACD.DIF#MONTH;
DEAM:=MACD.DEA#MONTH;
MACDM:=MACD.MACD#MONTH;
DIFA:EMA((DIFD+7*DIFW+31*DIFM)/39,5);
DEAA:EMA((DEAD+7*DEAW+31*DEAM)/39,5);
MACDA:EMA((MACDD+7*MACDW+31*MACDM)/39,5) COLORSTICK;
IF(DIFA<REF(DIFA,1),DIFA,DRAWNULL) COLORGREEN LINETHICK2;
IF(DIFA>=REF(DIFA,1),DIFA,DRAWNULL) COLORRED LINETHICK2;
STICKLINE(MACDA<REF(MACDA,1),0,MACDA,0.1,1),COLOR00FF5B;
趋势维持线:EMA(DIFA,10)COLORGREEN LINETHICK2;
IF(DIFA>=趋势维持线,趋势维持线,DRAWNULL)COLORYELLOW,LINETHICK2;
DRAWBAND(DIFA,RGB(244,0,0),趋势维持线,RGB(250,215,0));
{DIF15:=MACD.DIF#MIN15;
DEA15:=MACD.DIF#MIN15;
MACD15:=MACD.MACD#MIN15;
DIF30:=MACD.DIF#MIN30;
DEA30:=MACD.DEA#MIN30;
MACD30:=MACD.MACD#MIN30;
DIF60:=MACD.DIF#MIN60;
DEA60:=MACD.DEA#MIN60;
MACD60:=MACD.MACD#MIN60;
DIFS:(DIF15*3+DIF30*6+DIF60*12)/21 LINETHICK3 COLORRED;
DEAS:(DEA15*3+DEA30*6+DEA60*12)/21 LINETHICK3 COLORGREEN;
MACDS:(MACD15*3+MACD30*6+MACD60*12)/21 COLORSTICK LINETHICK3;
DRAWICON(crOSS(DEAS,DIFS),DIFS,24);
IF(DIFS<REF(DIFS,1),DIFS,DRAWNULL) COLORBLUE LINETHICK4;};

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【股先知公式】:通达信MACD长短牛熊指标公式 https://www.g3xs.com/13791.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视