【好用的公式】:通达信账户动态指标公式

2018-01-15 0 784

【好用的公式】:通达信账户动态指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

LINE:=0.1;
ROW:=0.05;
J1:=12.29;
S1:=300;
J2:=9.88;
S2:=410;
J3:=7.48;
S3:=200;
J4:=7.83;
S4:=300;
J5:=5;
S5:=500;
{横线}
{DRAwrECTREL(0,0,400,700,0);DRAWRECTREL(0,100,400,600,0);DRAWRECTREL(0,200,400,500,0);DRAWRECTREL(0,300,400,400,0);
{竖线}
{DRAWRECTREL(50,0,400,700,0);DRAWRECTREL(100,0,350,700,0);DRAWRECTREL(150,0,300,700,0);
DRAWRECTREL(200,0,250,700,0);}
DRAWTEXT_FIX(ISLAstBAR,0,0,0,’持股代码’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*1,0,0,’持股数量’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*2,0,0,’持股价格’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*3,0,0,’当前价格’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*4,0,0,’最新市值’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*5,0,0,’浮动盈亏’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*6,0,0,’盈亏比例’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,ROW*7,0,0,’当日盈亏’),COLORYELLOW;
{ 持股 1}
持股价1:=J1; 持股量1:=S1;{参数J1,S1分别是持股价格和持股数量,可以在参数表里改动}
当前价1:=”600856$CLOSE”; 昨收价1:=REF(“600856$CLOSE”,1);{自己的股票替换红色的股票代码}
最新市值1:=当前价1*持股量1; 浮动盈亏1:=最新市值1-持股价1*持股量1; 买入日期1:=1180110;{买入日期替换为自己的,前面的代表的是18年01月08日}
盈亏比例1:=浮动盈亏1/(持股价1*持股量1)*100; 当日盈亏1:=(当前价1-昨收价1)*持股量1*NOT(买入日期1=DATE);
清仓1:=NOT(0);{当清仓时为1,否则将1改为0}
DRAWTEXT_FIX(ISLASTBAR AND 清仓1 ,0,LINE*1,0,’600856′);
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*1,LINE*1,0,CON2STR(持股量1,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*2,LINE*1,0,CON2STR(持股价1,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*3,LINE*1,0,CON2STR(当前价1,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*4,LINE*1,0,CON2STR(最新市值1,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*5,LINE*1,0,CON2STR(浮动盈亏1,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*6,LINE*1,0,CON2STR(盈亏比例1,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓1,ROW*7+0.01,LINE*1,0,CON2STR(当日盈亏1,0));
{ 持股2 }
持股价2:=J2 ; 持股量2:=S2; 当前价2:=”000523$CLOSE”;昨收价2:=REF(“000523$CLOSE”,1);
最新市值2:=当前价2*持股量2; 浮动盈亏2:=最新市值2-持股价2*持股量2;盈亏比例2:=浮动盈亏2/(持股价2*持股量2)*100;
买入日期2:=1171001;当日盈亏2:=(当前价2-昨收价2)*持股量2*NOT(买入日期2=DATE);
清仓2:=NOT(0);
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,0,LINE*2,0,’000523′);
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*1,LINE*2,0,CON2STR(持股量2,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*2,LINE*2,0,CON2STR(持股价2,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*3,LINE*2,0,CON2STR(当前价2,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*4,LINE*2,0,CON2STR(最新市值2,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*5,LINE*2,0,CON2STR(浮动盈亏2,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*6,LINE*2,0,CON2STR(盈亏比例2,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓2,ROW*7+0.01,LINE*2,0,CON2STR(当日盈亏2,0));
{ 持股3 }
持股价3:=J3 ; 持股量3:=S3; 当前价3:=”601949$CLOSE”; 昨收价3:=REF(“601949$CLOSE”,1);
最新市值3:=当前价3*持股量3;浮动盈亏3:=最新市值3-持股价3*持股量3;盈亏比例3:=浮动盈亏3/(持股价3*持股量3)*100;
买入日期3:=1180108;当日盈亏3:=(当前价3-昨收价3)*持股量3*NOT(买入日期3=DATE);
清仓3:=NOT(0);
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,0,LINE*3,0,’601949′);
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*1,LINE*3,0,CON2STR(持股量3,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*2,LINE*3,0,CON2STR(持股价3,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*3,LINE*3,0,CON2STR(当前价3,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*4,LINE*3,0,CON2STR(最新市值3,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*5,LINE*3,0,CON2STR(浮动盈亏3,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*6,LINE*3,0,CON2STR(盈亏比例3,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓3,ROW*7+0.01,LINE*3,0,CON2STR(当日盈亏3,0));
{ 持股4 }
持股价4:=J4 ; 持股量4:=S4; 当前价4:=”600886$CLOSE”; 昨收价4:=REF(“600886$CLOSE”,1);
最新市值4:=当前价4*持股量4;浮动盈亏4:=最新市值4-持股价4*持股量4;盈亏比例4:=浮动盈亏4/(持股价4*持股量4)*100;
买入日期4:=1180107;当日盈亏4:=(当前价4-昨收价4)*持股量4*NOT(买入日期4=DATE);
清仓4:=NOT(1);
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,0,LINE*4,0,’600886′);
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*1,LINE*4,0,CON2STR(持股量4,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*2,LINE*4,0,CON2STR(持股价4,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*3,LINE*4,0,CON2STR(当前价4,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*4,LINE*4,0,CON2STR(最新市值4,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*5,LINE*4,0,CON2STR(浮动盈亏4,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*6,LINE*4,0,CON2STR(盈亏比例4,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓4,ROW*7+0.01,LINE*4,0,CON2STR(当日盈亏4,0));
{持股5}
持股价5:=J5 ; 持股量5:=S5; 当前价5:=”600886$CLOSE”; 昨收价5:=REF(“600886$CLOSE”,1);
最新市值5:=当前价5*持股量5;浮动盈亏5:=最新市值5-持股价5*持股量5;盈亏比例5:=浮动盈亏5/(持股价5*持股量5)*100;
买入日期5:=1180107;当日买入5:=0;当日盈亏5:=(当前价5-昨收价5)*持股量5*NOT(当日买入5);
清仓5:=NOT(1);
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,0,LINE*5,0,’600886′);
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*1,LINE*5,0,CON2STR(持股量5,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*2,LINE*5,0,CON2STR(持股价5,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*3,LINE*5,0,CON2STR(当前价5,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*4,LINE*5,0,CON2STR(最新市值5,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*5,LINE*5,0,CON2STR(浮动盈亏5,0));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*6,LINE*5,0,CON2STR(盈亏比例5,2));
DRAWTEXT_FIX(ISLASTBAR AND 清仓5,ROW*7+0.01,LINE*5,0,CON2STR(当日盈亏5,0));
{总计框}
{DRAWRECTREL(0,700,400,1000,RGB(139,0,139));}
持股个数:=清仓1+清仓2+清仓3+清仓4+清仓5;
总投入金:=J1*S1*清仓1+J2*S2*清仓2+J3*S3*清仓3+J4*S4*清仓4+J5*S5*清仓5;
持股市值:=最新市值1*清仓1+最新市值2*清仓2+最新市值3*清仓3+最新市值4*清仓4+最新市值5*清仓5;
总盈亏额:=持股市值-总投入金;
总盈亏比:=总盈亏额/总投入金*100;
当日盈亏:=当日盈亏1*清仓1+当日盈亏2*清仓2+当日盈亏3*清仓3+当日盈亏4*清仓4+当日盈亏5*清仓5;
DRAWTEXT_FIX(ISLASTBAR ,ROW*2.5,LINE*6,0,’★ 账 户 动 态 ★’),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*1,LINE*7,0,STRCAT(‘●持股个数: ‘,CON2STR(持股个数,0))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*4,LINE*7,0,STRCAT(‘●总投入金: ‘,CON2STR(总投入金,0))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*1,LINE*8,0,STRCAT(‘●持股市值: ‘,CON2STR(持股市值,0))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*4,LINE*8,0,STRCAT(‘●总盈亏额: ‘,CON2STR(总盈亏额,0))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*1,LINE*9,0,STRCAT(‘●总盈亏%: ‘,CON2STR(总盈亏比,3))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*4,LINE*9,0,STRCAT(‘●当日盈亏: ‘,CON2STR(当日盈亏,0))),COLORRED;
{右侧}
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*0,0,’★买卖操作警句★’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*0.5,0,’◇买入不急,卖出不贪,止损坚决,正在上涨的票才是最安全的’),COLORmaGENTA;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*1,0,’◇贪婪:便宜了还想再便宜,就是贪婪’),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*1.5,0,’◇恐惧:市场恐慌了,你更恐慌,就是恐惧’),COLORRED;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*2,0,’◇吃亏最大是企图抄在最低点的人和吃完最后晚餐的人’),COLORBROWN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*2.5,0,’◇涨得越高,跌得越深,涨得最慢,跌的更惨’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*3,0,’◇不要追求暴利,因为暴利是不稳定,要追求稳定的交易’),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*5,0,’★九阴真经时刻准备★’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*5.5,0,’量柱三阴:阴过阳,快逃亡(当前阴柱超过此前阳柱)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*6,0,’阴并阳,宜空仓(当前阴柱并肩此前阳柱)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*6.5,0,’倍量阴,出干净(当前阴柱倍量此前阳柱)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*7,0,’量价三阴:跳空阴,快出清(当前阴线跳离此前阳线)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*7.5,0,’阴盖阳,宜减仓(当前阴线长于此前阳线)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*8,0,’双阴露,往外吐(当前连续出现两根阴线)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*14,LINE*8.5,0,’量线三阴:阴破线,快走远(当前阴线跌破重要量线如黄金线)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*9,0,’阴出头,赶快走(当前阴线跌破重要支撑如平衡线)’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR ,ROW*15,LINE*9.5,0,’阴并阴,要当心(当前两根阴线并肩而立如双阴双柱)’),COLORGREEN;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【好用的公式】:通达信账户动态指标公式 https://www.g3xs.com/13677.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视