【好用的公式】:通达信好用的MACD指标公式

2018-01-24 0 384

【好用的公式】:通达信好用的MACD指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

VA:=IF(CLOSE>REF(CLOSE,1),vol,-VOL);
obv1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=Ema(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
Mac3:=MA(C,3);
SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
DEA:EMA(DIF,MID)COLORFF9900 ;
主力买:IF(DIF>REF(DIF,1),DIF,0),NODRAW;
主力卖:IF(DIF<REF(DIF,1),DIF,0),NODRAW;
macd:=(DIF-DEA)*2;
stICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,1.2,0),COLORYELLOW;
吸:=MACDREF(MACD,1);
拉:=MACD>0 AND MACD>REF(MACD,1);
派:=MACD>0 AND MACD<REF(MACD,1);
落:=MACD<0 AND MACD<REF(MACD,1);
STICKLINE(吸,0,MACD,0.5,0),COLORRED;
STICKLINE(拉,0,MACD,0.5,0),COLORRED;
STICKLINE(派,0,MACD,0.5,0),COLORGREEN;
STICKLINE(落,0,MACD,0.5,0),COLORWHITE;
主吸:吸,COLORYELLOW,NODRAW;
主拉:拉,COLORRED,NODRAW;
主派:派,COLORGREEN,NODRAW;
主砸:落,COLORFFAA00,NODRAW;
JCCOUNT:=COUNT(crOSS(DIF,DEA),BArslAST(DEA>=0));
低金:CROSS(DIF,DEA) AND DIF<-0.1,COLORWHITE,NODRAW;
二金:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,COLORRED,NODRAW;
STICKLINE(低金,0,0.08,2,0),COLORFF00FF;
DRAWTEXT(低金,0.16,’ 低位金叉’),COLORWHITE;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
底背:REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA),COLORGREEN,NODRAW;
STICKLINE(底背,0,0.03,2,0),COLOR00FF00;
DRAWTEXT(底背,0.12,’底背’),COLORFF00FF;
双金叉:低金 AND 二金,COLORFF00FF,NODRAW;
三全项:低金 AND 二金 AND 底背,COLORWHITE ,NODRAW;
顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);
STICKLINE(二金,0,0.06,2,0),COLORFFCC00;
DRAWICON(二金,DEA*0.9,1) ;
DRAWTEXT(二金,0.2,’ 二次金叉’),COLORYELLOW;
DRAWTEXT(低金 AND 二金 AND 底背,0.25,’三全项’),COLOR0000FF,LINETHICK2;
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORGREEN,LINETHICK2;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【好用的公式】:通达信好用的MACD指标公式 https://www.g3xs.com/13634.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视