【超好用公式】:通达信成功率极高的薛斯通道主图指标公式

2018-01-31 0 384

【超好用公式】:通达信成功率极高的薛斯通道主图指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

N:=102;
M:=7;
AA:=ma((2*CLOSE+HIGH+LOW)/4,5);
通道1:AA*N/100;
通道2:AA*(200-N)/100;
CC:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD;
通道4:(1-M/100)*DD;
DIF:=EMA(DCLOSE,9)-EMA(DCLOSE,17);
DEA:=EMA(DIF,6);
AAA:=(DIF-DEA)*2*60;
起爆:=crOSS(AAA-REF(AAA,1),12);
DRAWTEXT(起爆,L*0.975,’爆’),COLORRED;
DRAWTEXT(起爆,L*0.95,’涨’),COLORRED;
{红}
stICKLINE(起爆,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(起爆,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(起爆,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(起爆,CLOSE,OPEN,0.5,0),COLORCC66FF;
STICKLINE(起爆,OPEN,CLOSE,0.5,0),COLORYELLOW;
macd:=(DIF-DEA)*2,COLORSTICK;
TYP:=(HIGH+LOW+CLOSE)/3;
cci:=(TYP-MA(TYP,21))/(0.015*AVEDEV(TYP,21));
DRAWTEXT_FIX(ISLASTBAR,0.0,0,0,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,GNBLOCK),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,FGBLOCK),COLORWHITE;
{MA2报警器 k线图上变成蓝色,立马出局,别犹豫,切记};
VAR1P:=zig(3,13);
STICKLINE((REF(VAR1P,2) < REF(VAR1P,1)) AND (VAR1P < REF(VAR1P,1)),
CLOSE,OPEN,3,0),COLORBLUE;
DRAWICON(CROSS(REF(ZIG(3,12),1),ZIG(3,12)),HIGH*1.02,2);
STICKLINE((REF(VAR1P,2) > REF(VAR1P,1)) AND (VAR1P >REF(VAR1P,1)),
CLOSE,OPEN,3,0),COLORYELLOW;
DRAWICON(CROSS(ZIG(3,10),REF(ZIG(3,10),1)),LOW*0.99,1);
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAwrECTREL(15,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(47,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(107,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(141,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.015,1,0,’主力进出’),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.107,1,0,’散户进出’),COLORCYAN;
DRAWBMP((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*1.02,'BUY1');
DRAWBMP((ZIG(3,5)=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.03,’SELL1′);
DRAWTEXT(CROSS(83,rsi),H*1.04,’ 逃顶’)COLORYELLOW;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299,NODRAW;
顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BArslAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,DOTLINE;
低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;
STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORWHITE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,顶点,’顶点’),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,低点,’低点’),COLORRED;{COLORWHITE;};
{暴涨信号主图}
VAR5A:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
VAR6A:=EMA(VAR5A,9);
VAR7A:=(VAR5A-VAR6A)*2*60;
VAR8A:=CROSS(VAR7A-REF(VAR7A,1),15);
DRAWICON(VAR8A,LOW*1.09,25);
空:=EMA(CLOSE,5);
均衡:=EMA(空,0),COLORFFFFFF;
下趋势双线持币:HHV(MA(HIGH,3),2),LINETHICK0,COLORGREEN;
上趋势单线持股:LLV(MA(HIGH,3),1),LINETHICK0,COLORRED;
VAR5:=FILTER(均衡>REF(均衡,1) AND 下趋势双线持币REF(CLOSE,1),11);
IF(VAR5>=1,L*0.996,DRAWNULL),COLORMAGENTA,CIRCLEDOT;
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS(CLOSE-REF(CLOSE,1)),7)*100;
VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS(CLOSE-REF(CLOSE,1)),13)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR935;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGH(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
DRAWTEXT(买点1>0,LOW+0.2,’买’),COLORRED;
DRAWTEXT(买点2>0,LOW+0.2,’买’),COLORFF00FF;
DRAWTEXT(卖点1>0,HIGH+0.1,’逃’), COLOR33FF33;
黑马线:15,POINTDOT,COLORFFFFFF;
主力:VAR7A-REF(VAR7A,1),COLORRED;
DRAWICON(CROSS(主力,黑马线),黑马线,25);
LING0:0,POINTDOT,COLOR0FFFFF;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【超好用公式】:通达信成功率极高的薛斯通道主图指标公式 https://www.g3xs.com/13613.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视