【本月分享优秀公式】:通达信MACD顶底钝化指标公式

2018-02-01 0 864

【本月分享优秀公式】:通达信MACD顶底钝化指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

DIF:Ema(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
macd:(DIF-DEA)*2,COLORstICK;
SWIFTK:=’MacD.MACD’ * REF(‘MACD.MACD’,1)<0;
EARLYDAY_1:=BArslAST(REF(SWIFTK,1));
EARLYDAY_2:=BARSLAST(REF(SWIFTK,2));
EARLYDAY_3:=BARSLAST(REF(SWIFTK,3));
EARLYDAY_4:=BARSLAST(REF(SWIFTK,4));
EARLYDAY_5:=BARSLAST(REF(SWIFTK,5));
CLOW_0:=REF(LLV(MIN(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
CLOW_1:=REF(LLV(MIN(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
CLOW_2:=LLV(MIN(O,C),EARLYDAY_1);
DIFFLOW_0:=REF(LLV(‘MACD.DIFF’,EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
DIFFLOW_1:=REF(LLV(‘MACD.DIFF’,EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
DIFFLOW_2:=LLV(‘MACD.DIFF’,EARLYDAY_1);
钝化L:=
‘MACD.MACD'<0 AND (
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2) OR
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2)
);
结构L:=
‘MACD.MACD’REF(INTPART(‘MACD.DIFF’),1) AND (
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_1)>0 AND CLOW_1>CLOW_2 AND INTPART(‘MACD.DIFF’)>INTPART(DIFFLOW_2)) OR
(INTPART(DIFFLOW_2)-INTPART(DIFFLOW_0)>0 AND CLOW_0>CLOW_2 AND INTPART(‘MACD.DIFF’)>INTPART(DIFFLOW_2))
);
DRAWTEXT(钝化L,’MACD.DIFF’,’L’);
DRAWICON(结构L,’MACD.DIFF’,4);
CHIGH_0:=REF(HHV(MAX(O,C),EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
CHIGH_1:=REF(HHV(MAX(O,C),EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
CHIGH_2:=HHV(MAX(O,C),EARLYDAY_1);
DIFFHIGH_0:=REF(HHV(‘MACD.DIFF’,EARLYDAY_5-EARLYDAY_4-1),EARLYDAY_4+2);
DIFFHIGH_1:=REF(HHV(‘MACD.DIFF’,EARLYDAY_3-EARLYDAY_2-1),EARLYDAY_2+2);
DIFFHIGH_2:=HHV(‘MACD.DIFF’,EARLYDAY_1);
钝化H:=
‘MACD.MACD’>0 AND (
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2) OR
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2)
);
结构H:=
‘MACD.MACD’>0 AND INTPART(‘MACD.DIFF’)<REF(INTPART('MACD.DIFF'),1) AND(
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_1)<0 AND CHIGH_1<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2)) OR
(INTPART(DIFFHIGH_2)-INTPART(DIFFHIGH_0)<0 AND CHIGH_0<CHIGH_2 AND INTPART('MACD.DIFF')<INTPART(DIFFHIGH_2))
);
DRAWTEXT(钝化H,’MACD.DIFF’*1.02,’H’),COLORGREEN;
DRAWICON(结构H,’MACD.DIFF’,5),COLORGREEN;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【本月分享优秀公式】:通达信MACD顶底钝化指标公式 https://www.g3xs.com/13604.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视