【通用公式】:通达信机械量化MACD拐点指标公式

2018-03-07 0 882

【通用公式】:通达信机械量化MACD拐点指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

SHORT:=12;LONG:=26;M:=9;
C,COLORBLacK;
DIFF :=Ema(CLOSE,SHORT) – EMA(CLOSE,LONG);
DEA :=EMA(DIFF,M);
macd :=2*(DIFF-DEA);
JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}
DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}
DIF拐点:(DIFF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算今日DIFF=DIFF的对应股价}
金叉死叉:(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算金叉死叉的对应股价}
柱体变向:(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)));{计算MACD柱体变向时的对应股价};
IF(DIF拐点>=金叉死叉,DIF拐点,DRAWNULL),COLORRED,LINETHICK2;
IF(DIF拐点<金叉死叉,DIF拐点,DRAWNULL),COLORGREEN,LINETHICK2;
IF(柱体变向>=金叉死叉,柱体变向,DRAWNULL),COLORRED,LINETHICK2;
IF(金叉死叉>=柱体变向,金叉死叉,DRAWNULL),COLORBLUE,LINETHICK2;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【通用公式】:通达信机械量化MACD拐点指标公式 https://www.g3xs.com/13513.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视