【完美公式】:通达信机械量化MACD趋势指标公式

2018-03-07 0 538

【完美公式】:通达信机械量化MACD趋势指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

DIFF:=( Ema(CLOSE,12) – EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
macd:=2*(DIFF-DEA),stICK;
STICKLINE(DIFF<0,0,DIFF,2,0),COLORGREEN;
STICKLINE(DIFF>=0,0,DIFF,2,0),COLORRED;
STICKLINE(DEA>=0,0,DEA,2,-1),COLOR0000CC;
STICKLINE(DEA<0,0,DEA,2,-1),COLORGREEN;
柱1:=IF(DIFF>DEA,DIFF,0),COLORRED;
柱2:=IF(DEA<DIFF,DEA,0),COLORMAGENTA;
DRAWICON(crOSS(DIFF,DEA),柱2,1);
DRAWICON(CROSS(DEA,DIFF),DEA*1.1,2);
总涨跌比:DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100,COLORCYAN,NODRAW;
净资产:=FINANCE(34);
年ROE:FINANCE(33)/FINANCE(34)COLORCYAN,NODRAW;
PE:=DYNAINFO(39),COLORRED,NODRAW;
PB:CONST(DYNAINFO(7) / FINANCE(34))COLOREE3AB2,NODRAW;
投资回报率:年ROE/PB*100,COLOR0099FF,NODRAW;{每股收益年/C AND 1/PE;};
M:=9; SHORT:=12;LONG:=26;
JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}
DD:=(MacD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}
DIF拐头价:=(DIFF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORCYAN,LINETHICK3;
柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORGREEN;
DRAWTEXT_FIX(1,0.9,0.94,0,STRCAT(‘拐点价格: ‘,CON2STR(DIF拐头价,2))),COLORYELLOW;
DRAWNUMBER(DIFF>DEA,3,BArslAST(CROSS(DIFF,DEA))+1),COLORRED,NODRAW;
DRAWNUMBER(DIFF<DEA,-1,BARSLAST(CROSS(DEA,DIFF))+1),COLORGREEN,NODRAW;
DRAWTEXT_FIX(1,0.0,0.95,0,STRCAT(‘停止操作: ‘,CON2STR(CLOSE<MA(CLOSE,60),2))),COLORCYAN;
VA:=IF(CLOSE>REF(CLOSE,1),vol,-VOL);
obv1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,DEA/4,2,0),COLORYELLOW;
{mdiF:=2*(DIFF-DEA);
MDEA:=SMA(MDIF,5,2);
买卖力道:=2*(MDIF-MDEA),COLORCC0033,LINETHICK1;
DRAWBAND(MDIF,RGB(244,0,0),MDEA,RGB(0,0,244));};

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【完美公式】:通达信机械量化MACD趋势指标公式 https://www.g3xs.com/13512.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视