【新指标公式】:通达信附加大趋势指标公式

2018-03-13 0 162

【新指标公式】:通达信附加大趋势指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

小趋势:=0;
大趋势:=1;
选股线:=1;
选股线移动:=6;
均线上移:=0;
看高位:=0;
{波段操作 }
拉升力A:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,30)-LLV(LOW,36))*0.6*CLOSE;
拉升力B:=SMA(拉升力A,6.3,1)*1;
波峰波谷:=Sma(拉升力B,3,1),COLORFF00FF,COLOR000080;
拉升力:=3*拉升力B-2.1*波峰波谷,COLORLIGRAY;
看高:=IF(看高位=0,DRAWNULL,看高位);
隐藏:=IF(看高位=0,DRAWNULL,1);
另类趋势:=(3*拉升力B-2.1*波峰波谷)*看高,COLORLIGRAY;
DRAWBAND(另类趋势/隐藏,RGB(51,51,51),0/隐藏,RGB(0,0,0));
{配合特别指标观察k线趋势}
N2:=IF(选股线=0,DRAWNULL,选股线);
选2Q:BArslAst(MA(CLOSE,20)<MA(CLOSE,60)),COLORLIRED,NODRAW;
ST1:=N2*(-1);
ST2:=ST1+0.8;{定位}
STICKLINE(N2*(MA(CLOSE,20)>MA(CLOSE,60)),1*ST2+选股线移动,1*ST1+选股线移动,6,0),COLORLIRED;{上升区}
{000021圆弧底部K线};
N:=IF(小趋势=0,DRAWNULL,小趋势);
快线:N*(3*CLOSE+LOW+OPEN+HIGH)/6,COLOR855C82;{K线形态超短趋势,MA(CLOSE,1);相同};
H1:=EMA(CLOSE,8),LINETHICK1;
H2:N*EMA(H1,20),LINETHICK1,COLORWHITE;
MA10:N*MA(CLOSE,10),COLORYELLOW;
N3:=IF(大趋势=0,DRAWNULL,大趋势);
小:N3*EMA(CLOSE,55),COLORGREEN,LINETHICK2;
主:N3*EMA(CLOSE,105),COLORMAGENTA,LINETHICK2;
要:N3*EMA(CLOSE,180),COLORYELLOW,LINETHICK2;
大:N3*EMA(CLOSE,360),COLORCYAN,LINETHICK2;
VAR3:=EMA(CLOSE,180);
VAR4:=EMA(CLOSE,360);
金叉:1*N2*IF(crOSS(VAR3,VAR4),1,-1)+选股线移动,COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.15,0,’参数调整和选股’);
{—–选股上升区间————————————}
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
底部N:=IF(VAR9<-18,6,0),COLORFF3300,NODRAW;
启动:1*N2*IF(底部N>0,-1,0.2)+选股线移动,COLORGREEN,LINETHICK3;
周线:=(EMA(CLOSE,60)-EMA(CLOSE,26*5));
周底:=EMA(周线,9*5);
主升:N2*IF(周线>0,0.4,-1)*1+选股线移动,COLORLIMAGENTA,LINETHICK3;
N5:=250;
VAR5:=(3*SMA((CLOSE-LLV(LOW,N5))/(HHV(HIGH,N5)-LLV(LOW,N5))*100,20,1)+
2*SMA(SMA((CLOSE-LLV(LOW,N5))/(HHV(HIGH,N5)-LLV(LOW,N5))*100,20,1),15,1));
VAR55:=VAR5/4-15;
选股:1*N2*IF(VAR55>20,0.6,-1)+选股线移动,COLOR0099FF,LINETHICK2;
VAR450:=EMA(100*(CLOSE-LLV(LOW,450))/(HHV(HIGH,450)-LLV(LOW,450)),3);
区间:=IF(VAR450<10,0,1.5);
波段启动:1*N2*IF(区间>0,0.8,-1)+选股线移动,COLORLIBLUE,LINETHICK2;
{————–附图趋势线————————————-}
SNT:=要>大;
周期:BARSLAST(NOT(SNT)),COLORLIGRAY,NODRAW;
涨幅:(要/REF(要,周期)-1)*100,COLOR0099FF,NODRAW;
上移:=IF(均线上移=0,DRAWNULL,均线上移);{调整参数与大趋势比较};
VAR1:=SMA(O*AMOUNT/10000000,10,1)/100;
MA5:EMA(VAR1,5)*上移;
生命线:EMA(VAR1,10)*上移;
MA34:EMA(VAR1,23)*上移;
{—————多空线—————————}
X:=(3*C+L+O+H)/6;
多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)
+REF(X,20))/210,COLORRED,LINETHICK1; {就是牛线};
多头:IF(多空线>REF(多空线,1),MA10,DRAWNULL),,COLORRED,LINETHICK1;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【新指标公式】:通达信附加大趋势指标公式 https://www.g3xs.com/13490.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视