【一看就懂的公式】:通达信二日三线主图指标公式

2018-04-11 0 633

【一看就懂的公式】:通达信二日三线主图指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

VAR1:=IF(REF(HIGH,1)=REF(HHV(HIGH,2),1),1,0);
上线:IF(VAR1=1,REF(HIGH,1),REF(HIGH,2)),NODRAW;
VAR2:=IF(REF(LOW,1)=REF(LLV(LOW,2),1),1,0);
下线:IF(VAR2=1,REF(LOW,1),REF(LOW,2)),NODRAW;
中线:(上线+下线)/2,COLORmaGENTA,LINETHICK2;
IF(CLOSE<中线,中线,DRAWNULL),COLORLICYAN,LINETHICK2;
下三一:(上线-下线)*0.334+下线,COLORGREEN;
上三一:(上线-下线)*0.667+下线,COLORWHITE;
VAR3:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR4:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR3>=4.945;
VAR5:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR3<=(-4.945);
涨停价:IF(VAR4,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(VAR5,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
VAR6:=REF(CLOSE,1);
VAR7:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
stICKLINE(VAR7,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(VAR7,OPEN,CLOSE,1,0),COLORMAGENTA;
VAR8:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR8,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(VAR8,HIGH,LOW,0,1),COLORGREEN;
VAR9:=AMOUNT/vol/100;
VAR10:=CLOSE>OPEN AND REF(CLOSE,1)>VAR9 AND CLOSE>VAR9 AND CLOSE<300;
STICKLINE(VAR10,OPEN,CLOSE,1,0),COLORLICYAN;
VAR11:=OPEN>CLOSE AND CLOSEREF(CLOSE,1);
STICKLINE(VAR11,OPEN,CLOSE,1,0),COLORRED;
VAR12:=1;
VAR13:=CLOSE>500;
VAR14:=MAX(CLOSE,OPEN);
VAR15:=MIN(CLOSE,OPEN);
VAR16:=IF(VAR13,HIGH,VAR14);
VAR17:=IF(VAR13,LOW,VAR15);
VAR18:=IF(CLOSE>OPEN,IF(VAR12=0,LOW,VAR17),IF(VAR12=0,HIGH,VAR16));
VAR19:=VAR16-(VAR16-VAR17)/3;
VAR20:=VAR17+(VAR16-VAR17)/3;
VAR21:=VAR17+(VAR16-VAR17)/2;
VAR22:=1+IF(VAR13,2,4.92)/100;
VAR23:=VAR16/VAR17>=VAR22 OR CLOSE/REF(CLOSE,1)>=VAR22;
STICKLINE(VAR23,VAR19,VAR19,2,0),COLORBROWN;
STICKLINE(VAR23,VAR21,VAR21,3,0),COLORBROWN;
STICKLINE(VAR23,VAR20,VAR20,2,0),COLORBROWN;
VAR24:=1.3;
VAR25:=1;
VAR26:=0;
VAR27:=MA(CLOSE,5);
VAR28:=MA(CLOSE,10);
VAR29:=MA(CLOSE,20);
VAR30:=VAR27>REF(VAR27,1) AND VAR28<REF(VAR28,1) AND VAR29<REF(VAR29,1);
VAR31:=REF(VOL,1);
VAR32:=REF(VOL,2);
VAR33:=REF(VOL,3);
VAR34:=REF(CLOSE,1);
VAR35:=REF(CLOSE,2);
VAR36:=REF(CLOSE,3);
VAR37:=REF(CLOSE,4);
VAR38:=REF(OPEN,1);
VAR39:=REF(OPEN,2);
VAR40:=REF(OPEN,3);
VAR41:=REF(OPEN,4);
VAR42:=CLOSE>=VAR36 AND VAR34>=VAR36 AND VAR35>=VAR36;
VAR43:=LOW>VAR40 AND REF(LOW,1)>VAR40 AND REF(LOW,2)>VAR40;
VAR44:=AMOUNT/VOL/100;
VAR45:=REF(VAR44,1);
VAR46:=REF(VAR44,2);
VAR47:=CLOSE>=OPEN OR (CLOSEVAR34);
VAR48:=COUNT(VAR47,3)>=2;
VAR49:=VAR36>VAR40;
VAR50:=VAR44>=VAR45 OR CLOSE>VAR34 AND (VAR45>=VAR46 OR VAR34>=VAR35);
VAR51:=(CLOSE+VAR34+VAR35)/3>VAR36;
VAR52:=VOL>VAR31 AND VAR31>VAR32;
VAR53:=VOL<=VAR31 AND VAR31<=VAR32;
VAR54:=(VOL+VAR31+VAR32)/3<=VAR33 AND NOT(VAR52);
VAR55:=CLOSE/VOL;
VAR56:=VAR55>=REF(VAR55,1) AND REF(VAR55,1)>=REF(VAR55,2);
VAR57:=(CLOSE+VAR34+VAR35)/3/VAR36;
VAR58:=(VOL+VAR31+VAR32)/3/VAR33;
VAR59:=VAR24*VAR57/VAR58>1;
VAR60:=VAR40>VAR37 AND VAR37>VAR41;
VAR61:=VAR49 AND VAR50 AND VAR53 AND VAR42 AND VAR43 AND VAR60;
VAR62:=BacKSET(VAR61,5);
VAR63:=FILTER(VAR62,4);
VAR64:=VAR49 AND VAR50 AND VAR53 AND VAR42 AND VAR43;
VAR65:=BACKSET(VAR64,4);
VAR66:=FILTER(VAR65,3);
VAR67:=VAR64 AND REF(VAR64,1);
VAR68:=BACKSET(VAR67,4);
VAR69:=FILTER(VAR68,3);
VAR70:=VAR64 AND REF(VAR64,2);
VAR71:=BACKSET(VAR70,4);
VAR72:=FILTER(VAR71,3);
VAR73:=VAR64 AND REF(VAR64,3);
VAR74:=BACKSET(VAR73,4);
VAR75:=FILTER(VAR74,3);
VAR76:=VAR49 AND VAR50 AND VAR54 AND NOT(VAR52) AND VAR42 AND VAR43 AND VAR60 AND NOT(VAR64) AND NOT(VAR61);
VAR77:=BACKSET(VAR76,5);
VAR78:=FILTER(VAR77,4);
VAR79:=VAR49 AND VAR50 AND VAR54 AND NOT(VAR52) AND VAR42 AND VAR43 AND NOT(VAR64) AND NOT(VAR61);
VAR80:=BACKSET(VAR79,4);
VAR81:=FILTER(VAR80,3);
VAR82:=VAR79 AND REF(VAR79,1);
VAR83:=BACKSET(VAR82,4);
VAR84:=FILTER(VAR83,3);
VAR85:=VAR79 AND REF(VAR79,2);
VAR86:=BACKSET(VAR85,4);
VAR87:=FILTER(VAR86,3);
VAR88:=VAR79 AND REF(VAR79,3);
VAR89:=BACKSET(VAR88,4);
VAR90:=FILTER(VAR89,3);
VAR91:=VAR49 AND VAR51 AND VAR53 AND VAR42 AND VAR43 AND VAR60 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR61) AND NOT(VAR76);
VAR92:=BACKSET(VAR91,5);
VAR93:=FILTER(VAR92,4);
VAR94:=VAR49 AND VAR51 AND VAR53 AND VAR42 AND VAR43 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR61) AND NOT(VAR76);
VAR95:=BACKSET(VAR94,4);
VAR96:=FILTER(VAR95,3);
VAR97:=VAR94 AND REF(VAR94,1);
VAR98:=BACKSET(VAR97,4);
VAR99:=FILTER(VAR98,3);
VAR100:=VAR94 AND REF(VAR94,2);
VAR101:=BACKSET(VAR100,4);
VAR102:=FILTER(VAR101,3);
VAR103:=VAR94 AND REF(VAR94,3);
VAR104:=BACKSET(VAR103,4);
VAR105:=FILTER(VAR104,3);
VAR106:=VAR49 AND VAR51 AND VAR54 AND VAR42 AND VAR43 AND VAR60 AND NOT(VAR64) AND NOT(VAR61) AND NOT(VAR79) AND NOT(VAR76) AND NOT(VAR94) AND NOT(VAR91);
VAR107:=BACKSET(VAR106,5);
VAR108:=FILTER(VAR107,4);
VAR109:=VAR49 AND VAR51 AND VAR54 AND VAR42 AND VAR43 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR94) AND NOT(VAR61) AND NOT(VAR76) AND NOT(VAR91);
VAR110:=BACKSET(VAR109,4);
VAR111:=FILTER(VAR110,3);
VAR112:=VAR109 AND REF(VAR109,1);
VAR113:=BACKSET(VAR112,4);
VAR114:=FILTER(VAR113,3);
VAR115:=VAR109 AND REF(VAR109,2);
VAR116:=BACKSET(VAR115,4);
VAR117:=FILTER(VAR116,3);
VAR118:=VAR109 AND REF(VAR109,3);
VAR119:=BACKSET(VAR118,4);
VAR120:=FILTER(VAR119,3);
VAR121:=VAR49 AND VAR51 AND VAR59 AND VAR42 AND VAR43 AND VAR60 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR94) AND NOT(VAR109) AND NOT(VAR61) AND NOT(VAR76) AND NOT(VAR91) AND NOT(VAR106);
VAR122:=BACKSET(VAR121,5);
VAR123:=FILTER(VAR122,4);
VAR124:=VAR49 AND VAR51 AND VAR59 AND VAR42 AND VAR43 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR94) AND NOT(VAR109) AND NOT(VAR61) AND NOT(VAR76) AND NOT(VAR91) AND NOT(VAR106);
VAR125:=BACKSET(VAR124,4);
VAR126:=FILTER(VAR125,3);
VAR127:=VAR124 AND REF(VAR124,1);
VAR128:=BACKSET(VAR127,4);
VAR129:=FILTER(VAR128,3);
VAR130:=VAR124 AND REF(VAR124,2);
VAR131:=BACKSET(VAR130,4);
VAR132:=FILTER(VAR131,3);
VAR133:=VAR124 AND REF(VAR124,3);
VAR134:=BACKSET(VAR133,4);
VAR135:=FILTER(VAR134,3);
VAR136:=VAR49 AND VAR51 AND VAR56 AND VAR42 AND VAR43 AND VAR60 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR94) AND NOT(VAR109) AND NOT(VAR124) AND NOT(VAR61) AND NOT(VAR76) AND NOT(VAR91) AND NOT(VAR106) AND NOT(VAR121);
VAR137:=BACKSET(VAR136,5);
VAR138:=FILTER(VAR137,4);
VAR139:=VAR49 AND VAR51 AND VAR56 AND VAR42 AND VAR43 AND NOT(VAR64) AND NOT(VAR79) AND NOT(VAR94) AND NOT(VAR109) AND NOT(VAR124) AND NOT(VAR61) AND NOT(VAR76) AND NOT(VAR91) AND NOT(VAR106) AND NOT(VAR121);
VAR140:=BACKSET(VAR139,4);
VAR141:=FILTER(VAR140,3);
VAR142:=VAR139 AND REF(VAR139,1);
VAR143:=BACKSET(VAR142,4);
VAR144:=FILTER(VAR143,3);
VAR145:=VAR139 AND REF(VAR139,2);
VAR146:=BACKSET(VAR145,4);
VAR147:=FILTER(VAR146,3);
VAR148:=VAR139 AND REF(VAR139,3);
VAR149:=BACKSET(VAR148,4);
VAR150:=FILTER(VAR149,3);
VAR151:=VAR66 AND NOT(REF(VAR66,4)) OR (VAR69 AND NOT(REF(VAR69,4))) OR (VAR72 AND NOT(REF(VAR72,4))) OR (VAR75 AND NOT(REF(VAR75,4)));
VAR152:=VAR81 AND NOT(REF(VAR81,4)) OR (VAR84 AND NOT(REF(VAR84,4))) OR (VAR87 AND NOT(REF(VAR87,4))) OR (VAR90 AND NOT(REF(VAR90,4)));
VAR153:=VAR96 AND NOT(REF(VAR96,4)) OR (VAR99 AND NOT(REF(VAR99,4))) OR (VAR102 AND NOT(REF(VAR102,4))) OR (VAR105 AND NOT(REF(VAR105,4)));
VAR154:=VAR111 AND NOT(REF(VAR111,4)) OR (VAR114 AND NOT(REF(VAR114,4))) OR (VAR117 AND NOT(REF(VAR117,4))) OR (VAR120 AND NOT(REF(VAR120,4)));
VAR155:=VAR126 AND NOT(REF(VAR126,4)) OR (VAR129 AND NOT(REF(VAR129,4))) OR (VAR132 AND NOT(REF(VAR132,4))) OR (VAR135 AND NOT(REF(VAR135,4)));
VAR156:=VAR141 AND NOT(REF(VAR141,4)) OR (VAR144 AND NOT(REF(VAR144,4))) OR (VAR147 AND NOT(REF(VAR147,4))) OR (VAR150 AND NOT(REF(VAR150,4)));
VAR157:=VAR151 OR VAR152 OR VAR153 OR VAR154 OR VAR155 OR VAR156;
STICKLINE(VAR157 AND NOT(REF(VAR157,4)),OPEN,CLOSE,1,0),COLOR0099FF;
VAR158:=SUMBARS(VAR157,1);
VAR159:=VAR63 AND NOT(REF(VAR63,5));
VAR160:=VAR78 AND NOT(REF(VAR78,5));
VAR161:=VAR93 AND NOT(REF(VAR93,5));
VAR162:=VAR108 AND NOT(REF(VAR108,5));
VAR163:=VAR123 AND NOT(REF(VAR123,5));
VAR164:=VAR138 AND NOT(REF(VAR138,5));
VAR165:=VAR159 OR VAR160 OR VAR161 OR VAR162 OR VAR163 OR VAR164;
STICKLINE(VAR165 AND NOT(REF(VAR165,5)),OPEN,CLOSE,1,0),COLORRED;
VAR166:=SUMBARS(VAR165,1);
VAR167:=VAR64 OR VAR79 OR VAR94 OR VAR109 OR VAR124 OR VAR139 AND VAR30 AND VAR26;
VAR168:=BACKSET(VAR167,4);
VAR169:=FILTER(VAR168,3);
STICKLINE(VAR169 AND NOT(REF(VAR169,4)),OPEN,CLOSE,1,0),COLOR0099FF;
VAR170:=VAR61 OR VAR76 OR VAR91 OR VAR106 OR VAR121 OR VAR136 AND VAR30 AND VAR26;
VAR171:=BACKSET(VAR170,5);
VAR172:=FILTER(VAR171,5);
STICKLINE(VAR172 AND NOT(REF(VAR172,4)),OPEN,CLOSE,1,0),COLOR0099FF;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【一看就懂的公式】:通达信二日三线主图指标公式 https://www.g3xs.com/13384.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视