【本月分享优秀公式】:通达信潜伏黄金坑指标公式

2019-09-24 0 661

【本月分享优秀公式】:通达信潜伏黄金坑指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

N:=14;
M:=6;
NC:=14;
MTR:=SUM(maX(MAX(HIGH-LOW,Abs(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=SUM(IF(HD>0&&HD>LD,HD,0),N);
DMM:=SUM(IF(LD>0&&LD>HD,LD,0),N);
pdi: DMP*100/MTR;
mdi: DMM*100/MTR;
ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:(ADX+REF(ADX,M))/2;
看多线:20,DOTLINE,COLORRED;
MA5:=MA(C,5);MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);MA60:=MA(C,60);
MAX1:=MAX(MA5,MA10);
MAX2:=MAX(MAX1,MA20);
MAX3:=MAX(MAX2,MA30);
MAXH:=MAX(MAX3,MA60);
MIN1B:=MIN(MA5,MA10);
MIN2:=MIN(MIN1B,MA20);
MIN3:=MIN(MIN2,MA30);
MINL:=MIN(MIN3,MA60);
粘合度:=(MAXH-MINL)/MINL*100;
多头发散:=MA5>REF(MA5,1) AND MA5>MA10 AND MA10>=REF(MA10,1) AND MA10>MA20 AND MA20>=REF(MA20,1) AND MA20>MA30 AND MA30>=REF(MA30,1) AND MA30>MA60 AND MA60>=REF(MA60,1);
选股:BArslAstCOUNT(粘合度<=5)=2 AND 多头发散;
DRAWTEXT(crOSS(PDI,MDI) AND EXIST(粘合度REF(MA(C,20),1)-REF(MA(C,20),2)
AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),38,’多’),COLORRED;
DRAWTEXT(CROSS(PDI,MDI) AND EXIST(粘合度REF(MA(C,20),1)-REF(MA(C,20),2)
AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1),48,’看’),COLORRED;
DRAWTEXT(CROSS(MDI,PDI),38,’看’),COLORGREEN;
DRAWTEXT(CROSS(MDI,PDI),26,’空’),COLORGREEN;
DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)
,28,’主’),COLORRED;
DRAWTEXT(CROSS(PDI,MDI) AND ADX>20 AND ADXR>20 AND MA(C,10)>REF(MA(C,10),1)
,18,’升’),COLORRED;
DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDIREF(ADX,1) AND ADXR>REF(ADXR,1)
AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND
ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,58,’走’),COLORRED;
DRAWTEXT(CROSS(PDI,ADX) AND CROSS(PDI,ADXR) AND MDIREF(ADX,1) AND ADXR>REF(ADXR,1)
AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND
ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45,48,’牛’),COLORRED;
升1:=CROSS(ADXR,20) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;
升2:=CROSS(ADX,20) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;
升3:=CROSS(PDI,20) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60;
升4:=CROSS(20,MDI) AND ATAN(((2*REF(MDI,1)-MDI)/REF(MDI,1)-1)*100)*180/3.1416>45;
反降:=MDI45;
升:=升1 OR 升2 OR 升3 OR 升4;
DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),46,’升’),COLORRED;
DRAWTEXT(升 AND 反降 AND ADX>20 AND ADXR>20 AND PDI>20 AND ADX>REF(ADX,1) AND PDI>=REF(PDI,1) AND MA(C,5)>REF(MA(C,5),1),36,’势’),COLORRED;
DRAWTEXT(ADX<REF(ADX,1) AND ADXR<REF(ADXR,1) AND PDIREF(MDI,1)
AND MA(C,5)<REF(MA(C,5),1),44,'降'),COLORGREEN;
DRAWICON(CROSS(PDI,MDI),PDI,1);
DRAWICON(CROSS(MDI,PDI),MDI,2);
DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDIREF(MA(C,5),1) AND PDI>MDI,22,’短’),COLORRED;
DRAWTEXT(CROSS(PDI,ADXR) AND ATAN((PDI/REF(PDI,1)-1)*100)*180/3.1416>60 AND MDIREF(MA(C,5),1) AND PDI>MDI,18,’升’),COLORRED;
{黄金坑}
RR1:=MA(CLOSE,27);
RR2:=(CLOSE-RR1)/RR1*100;
RRA:=MA(RR2,2);
RRB:=BARSLAST(CROSS(-10,RRA)=1);
RRD:=RRA3;
黄金坑:=IF(RRD,-120,0);
{cci}
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,NC))/(0.015*AVEDEV(TYP,NC));
DRAWTEXT(CROSS(CCI,0),66,’上’),COLORRED;
DRAWTEXT(CROSS(0,CCI),66,’下’),COLORGREEN;
DRAWTEXT(CROSS(CCI,100),56,’突’),COLORRED;
DRAWTEXT(CROSS(100,CCI),56,’落’),COLORGREEN;
DRAWTEXT(CROSS(100,CCI) AND MA(C,20)>REF(MA(C,20),1),60,’暂’),COLORGREEN;
叉1:=CROSS(ADX,0) AND ATAN((ADX/REF(ADX,1)-1)*100)*180/3.1416>60;
叉2:=CROSS(ADXR,0) AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60;
叉3:=CROSS(20,PDI) AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45;
叉4:=CROSS(MDI,20) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45;
叉:=叉1 OR 叉2 OR 叉3 OR 叉4;
逆势:=MDI>REF(MDI,1) AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>45 AND MDI>20;
DRAWTEXT(叉 AND 逆势 AND PDI20 AND ADX>20 AND ADXR>20,54,’跌’),COLORGREEN;
DRAWTEXT(叉 AND 逆势 AND PDI20 AND ADX>20 AND ADXR>20,50,’势’),COLORGREEN;
跌角1:=ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60 AND ATAN((ADXR/REF(ADXR,1)-1)*100)*180/3.1416>60
AND ATAN((MDI/REF(MDI,1)-1)*100)*180/3.1416>60 AND ADXR>20 AND ADX>20 AND MDI>20 AND MDI>REF(MDI,1);
DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),34,'大'),COLORGREEN;
DRAWTEXT(跌角1 AND ATAN(((2*REF(PDI,1)-PDI)/REF(PDI,1)-1)*100)*180/3.1416>45 AND MA(C,10)<REF(MA(C,10),1),30,'跌'),COLORGREEN;
潜伏:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND
MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5);
潜伏2:=CROSS(PDI,MDI) AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1) AND
MA(C,20)-REF(MA(C,20),1)>REF(MA(C,20),1)-REF(MA(C,20),2) AND EXIST(粘合度<=8,5) AND EXIST(黄金坑,10);
DRAWTEXT(潜伏,14,’潜’),COLORYELLOW;
DRAWTEXT(潜伏,10,’伏’),COLORYELLOW;
DRAWTEXT(潜伏2,6,’潜’),COLORRED;
DRAWTEXT(潜伏2,2,’伏’),COLORRED;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【本月分享优秀公式】:通达信潜伏黄金坑指标公式 https://www.g3xs.com/11613.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视