【易拉公式】:通达信绝妙箱体主图指标公式

2019-11-21 0 790

【易拉公式】:通达信绝妙箱体主图指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

VARX:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARX1:=SMA(VARX,3,1);
VARX2:=Sma(VARX1,3,1);
VARX3:=REF(LOW,1);
VARX4:=SMA(Abs(LOW-VARX3),3,1)/SMA(MAX(LOW-VARX3,0),3,1)*100;
VARX5:=EMA(IF(CLOSE*1.2,VARX4*10,VARX4/10),3);
VARX6:=LLV(LOW,30);
VARX7:=HHV(VARX5,30);
VARX8:=IF(LLV(LOW,58),1,0); 筹码短期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,vol/(SUM(AMOUNT,8)/(AMOUNT/VOL/100)/100));
筹码中期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100));
筹码长期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,20)/(AMOUNT/VOL/100)/100));DIF:=EMA(EMA(CLOSE,18)-EMA(CLOSE,34),11);
macd:=EMA(EMA(DIF,11),11),COLOR58FF58;
DEF:=2*(DIF-MacD),COLORFFFF00,LINETHICK0;
mms:=((100)*(EMA(EMA(mtm,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
VARR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VARR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VARR3:=(2*CLOSE+HIGH+LOW)/4;
VARR4:=LLV(LOW,26);
VARR5:=HHV(HIGH,34);
VARR6:=EMA((VARR3-VARR4)/(VARR5-VARR4)*100,16);
VARR7:=SMA((SMA(VARR2,3,1)+3),3,1),LINETHICK3;
VARR8:=EMA(VARR6,7);
VARR9:=SMA(VARR1,3,1);
VARR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VARR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VARR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VARR13:=(VARR10+VARR11+VARR12)/3;
VARR14:=IF(VARR13<=-20,10,0);
VARR15:=HHV(VARR14,10);
VARR24:=LLV(LOW,36);
VARR25:=HHV(HIGH,30);
VARR26:=EMA((CLOSE-VARR24)/(VARR25-VARR24)*4,4)*25;
VARB27:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)/2+22)*1;
VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);
箱顶:HHV(MA((CLOSE),5),30)COLORRED,LINETHICK2;
箱底:LLV(MA((CLOSE),5),30) ;
长底:LLV(MA((CLOSE),5),120)LINETHICK2;
JJ:=(CLOSE+HHV(MA((CLOSE),5),2)+LLV(MA((CLOSE),5),2))/3;
DARS:=IF((DATETODAY(DATE))<9999,1,DRAWNULL);
AA:=EMA(JJ,3)*DARS;
BB:=REF(AA,1);
stICKLINE(AA>BB,AA,BB,3,0),COLORYELLOW,;
STICKLINE(AA<BB,AA,BB,3,0),COLORLICYAN,;
XSR:=1970330;XS:=IF(DATE<XSR,1,DRAWNULL);DS:="mfi.MFI"(12,9)*XS;{反特别版处理}A9:= DATETODAY(DATE)*XS;{反特别版处理}
DS1:=IF(A9<9999{0324},4.55,-DS);DS31:=IF(A9<9999{90324},4.7,-DS);DS41:=IF(A9<9999{324},4.45,-DS);DS51:=IF(A9<9999{2094},4.75,-DS);DS61:=IF(A9<9999{0324},4.65,-DS);DS71:=IF(A9<9999{0324},4.5,-DS);DS81:=IF(A9<9999{2094},4.6,-DS);
DS2:=IF(A9<9999{230},0.01,-DS);DS5:=IF(A9<9999{200},0.02,-DS);DS7:=IF(A9<9999{2},0.03,-DS);DS9:=IF(A9<9999{230},0.04,-DS);DS11:=IF(A9<9999{230},0.05,-DS);
DS13:=IF(A9<9999{30},0.06,-DS);DS15:=IF(A9<9999{20},0.002,-DS);DS17:=IF(A9<9999{230},0.004,-DS);DS19:=IF(A9<9999{230},0.006,-DS);DS21:=IF(A9<9999{230},0.008,-DS);
AJ2:=A9>146 AND A9144 AND A9142 AND A9140 AND A9138 AND A9136 AND A9134 AND A9<136;
AI29:=A9>704 AND A9702 AND A9698 AND A9696 AND A9694 AND A9<696;
AI22:=A9>692 AND A9690 AND A9688 AND A9686 AND A9684 AND A9<686;
AH2:=A9>1315 AND A91311 AND A91309 AND A91307 AND A9<1309;
AH24:=A9>1305 AND A91303 AND A91299 AND A91297 AND A9<1299;
AA28:=A9>1860 AND A91856 AND A91854 AND A91852 AND A91848 AND A9<1850;
AA23:=A9>1846 AND A91844 AND A91842 AND A91840 AND A9<1842;
AL2:=A9>3290 AND A93066 AND A93288 AND A93292 AND A93294 AND A9<3296;
AL25:=A9>3296 AND A93068 AND A993054 AND A993020 AND A9<3044;
AK27:=A9>4711 AND A94709 AND A94707 AND A94705 AND A94703 AND A9<4705;
AK24:=A9>4701 AND A94699 AND A94697 AND A94695 AND A9<4697;
AB2:=A9>5280 AND A95278 AND A95276 AND A95274 AND A9<5276;
AB24:=A9>5272 AND A95270 AND A95268 AND A95266 AND A9<5268;
AC2:=A9>6520 AND A96523 AND A96526 AND A96529 AND A96532 AND A9<6535;
AE2:=A9>6828 AND A97132 AND A97134 AND A97136 AND A97138 AND A9<7140;
AG2:=A9>7337 AND A97339 AND A97341 AND A9<7343;
AX2:=A9>8014 AND A98016 AND A98018 AND A9<8020;
AP2:=A9>8480 AND A98482 AND A98484 AND A9<8486;
AQ:=A9>8558 AND A98556 AND A98554 AND A98552 AND A98550 AND A9<8552;
AQ23:=A9>8548 AND A98546 AND A98544 AND A98542 AND A98540 AND A9<8542;
AM2:=A9>99015 AND A999017 AND A999019 AND A999021 AND A999023 AND A9<9025;
AM25:=A9>99025 AND A999027 AND A999029 AND A999037 AND A9<9040;
AH1:=A9>786 AND A9784 AND A9782 AND A9794 AND A9792 AND A9790 AND A9788 AND A9<790;
AI1:=A9>520 AND A9530 AND A9522 AND A9528 AND A9526 AND A9524 AND A9522 AND A9<524;
AG1:=A9>1360 AND A91358 AND A91356 AND A91354 AND A9<1356;
AG14:=A9>1366 AND A91364 AND A91362 AND A9<1364;
AL1:=A9>2333 AND A92331 AND A92329 AND A92327 AND A92325 AND A9<2327;
AL15:=A9>2323 AND A92321 AND A92319 AND A9<2321;
AA1:=A9>3826 AND A93824 AND A93822 AND A93820 AND A93818 AND A9<3820;
AA15:=A9>3816 AND A93814 AND A93812 AND A9<3814;
AK1:=A9>4856 AND A94854 AND A94852 AND A94850 AND A9<4852;
AK14:=A9>4848 AND A94846 AND A94844 AND A94842 AND A9<4844;
AB0:=A9>6140 AND A96142 AND A96144 AND A96146 AND A9<6148;
AB13:=A9>6148 AND A96152 AND A96154 AND A96156 AND A96158 AND A96160 AND A9<6162;
AC1:=A9>6802 AND A96800 AND A96798 AND A96796 AND A96794 AND A96792 AND A9<6794;
AC16:=A9>96790 AND A996788 AND A9<6790;
AE14:=A9>6914 AND A96908 AND A96910 AND A96912 AND A9<6914;
AF1:=A9>7258 AND A97260 AND A97262 AND A97264 AND A9<7266;
AX1:=A9>7422 AND A97420 AND A97418 AND A98095 AND A9<8099;
AWP1:=A9>8932 AND A98934 AND A98936 AND A98938 AND A98942 AND A98944 AND A98946 AND A9<8948;
个股:=5*POW(SMA((C-LLV(L,65))/(HHV(H,65)-LLV(L,65)*DARS),6,1),2)*XS;
{}Y1:=IF(A9<8948,0.5*(AWP15+AWP16+AWP13+AWP14+AK17+AH11+AH12+AH13+AH14+AH15+AH16+AI11+AI12+AI13+AI14+AI15+AI16+AG11+AG12+AG13+AG14+AG15+AG16+AL11+AL12+AL13+AL14+AL15+AL16+AL17+AA11+AA12+AA13+AA14+AA15+AA16+AA17+AK11+AK12+AK13+AK14+AK15+AK16+AWP12+AWP11+AWP1+AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111+AE11+AE12+AE14+AC11+AC12+AC13+AC14+AC15+AC16+AC17+AB11+AB12+AB13+AB14+AB15+AB16+AB17+AB0+AB18)*14,DS1)*DARS;{反特别版处理}
{}Y31:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS31);{反特别版处理}
{}Y41:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS41);{反特别版处理}
{}Y51:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS51);{反特别版处理}
{}Y61:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
}Y71:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
Y81:=IF(A9<8940,0.5*(AA1+AB1+AC1+AE1+AF1+AG1+AH1+AI1+AK1+AL1+AX1+AW1+AW11+AX11+AF11+AF111+AF1111)*14,DS61);{反特别版处理}
{}Y2:=IF(A9<9050,0.5*(AI29+AF23+AF21+AF22+AK27+AK28+AL27+AL28+AA27+AA28+AI27+AI28+AJ21+AJ22+AJ23+AJ24+AJ25+AJ26+AI21+AI22+AI23+AI24+AI25+AI26+AH21+AH22+AH23+AH24+AH25+AH26+AH27+AA21+AA22+AA23+AA24+AA25+AA26+AL21+AL22+AL23+AL24+AL25+AL26+AK21+AK22+AK23+AK24+AK25+AK26+AB2+AB21+AB22+AB23+AB24+AB25+AB26+AB27+AM28+AM27+AM26+AM25+AM24+AM23+AM22+AM21+AM2+AA2+AH2+AI2+AJ2+AK2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222+AQ23+AQ24+AQ25+AQ26+AQ27+AC21+AC22+AC23+AC24),DS2)*DARS;{反特别版处理}
{}Y5:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS5);{反特别版处理}
{}Y7:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS7);{反特别版处理}
{}Y9:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS9);{反特别版处理}
{}Y11:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS11);{反特别版处理}
{}Y13:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS13);{反特别版处理}
{}Y15:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS15);{反特别版处理}
{}Y17:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS17);{反特别版处理}
{}Y19:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS19);{反特别版处理}
{}Y21:=IF(A9<9050,0.5*(AA2+AH2+AI2+AJ2+AL2+AC2+AE2+AF2+AG2+AX2+AP2+AX22+AX222+AP22+AP222+AQ2+AQ22+AQ222+AQ+AQ2222+AG22+AG222),DS21);{反特别版处理}
Y3:=crOSS(Y2,个股);Y4:=CROSS(Y1,个股) AND 个股>0.6;Y32:=CROSS(Y31,个股) AND 个股>0.6;Y42:=CROSS(Y41,个股) AND 个股>0.6;Y52:=CROSS(Y51,个股) AND 个股>0.6;
Y62:=CROSS(Y61,个股) AND 个股>0.6;Y72:=CROSS(Y71,个股) AND 个股>0.6;Y82:=CROSS(Y81,个股) AND 个股>0.6;
Y6:=CROSS(Y5,个股);Y8:=CROSS(Y7,个股);Y10:=CROSS(Y9,个股);Y12:=CROSS(Y11,个股);Y14:=CROSS(Y13,个股);Y16:=CROSS(Y15,个股);
Y18:=CROSS(Y17,个股);Y20:=CROSS(Y19,个股);Y22:=CROSS(Y21,个股);
DRAWICON((Y4 > 0),箱顶*1.03,2);DRAWICON((Y32> 0),箱顶*1.03,2);DRAWICON((Y42 > 0),箱顶*1.03,2);DRAWICON((Y52 > 0),箱顶*1.03,2);
DRAWICON((Y62 > 0),箱顶*1.03,2);DRAWICON((Y72 > 0),箱顶*1.03,2);DRAWICON((Y82 > 0),箱顶*1.03,2);
DRAWICON((Y3 > 0),长底,1);DRAWICON((Y6> 0),长底,1);DRAWICON((Y8> 0),长底,1);DRAWICON((Y10 > 0),长底,1);DRAWICON((Y12 > 0),长底,1);
DRAWICON((Y14 > 0),长底,1);DRAWICON((Y16 > 0),长底,1);DRAWICON((Y18> 0),长底,1);DRAWICON((Y20> 0),长底,1);DRAWICON((Y22 > 0),长底,1);
Z1:=STRCAT(HYBLOCK,’ ‘);
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,’ ‘);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【易拉公式】:通达信绝妙箱体主图指标公式 https://www.g3xs.com/11393.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视