【通用公式】:通达信规避踩雷指标公式

2019-11-27 0 706

【通用公式】:通达信规避踩雷指标公式

股池网温馨提醒:该技术指标适用于股票技术研究,不对投资结果负责。如需免费复制公式指标请先会员登陆如需免费复制指标请【先注册会员】
加入公式方法:在软件里面按Crtl+F键–在“技术指标公式”下方点击“其它类型”–点击“新建”–填写公式名称–把指标公式代码复制到底部大框框–(如果此代码为副图,请在画线方法中选择副图,如果是主图,请在画线方法中选择“主图叠加”)–保存–在副图指标里调取即可。

DRAwrECTREL(0,0,990,990,RGB(20,18,12));
DRAWTEXT_FIX(1,0.14,0.01,1,’股东股份:’),COLORRED;
品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.14,0.15,1,’品种类型:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.25,1,’所属板块:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.35,1,’上市天数:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.45,1,’股总市值:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.55,1,’流通市值:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.65,1,’股东人数:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.14,0.75,1,’人均持股:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.23,0.25,1,HYBLOCK),COLORLIGREEN;
DRAWNUMBER_FIX(1,0.2,0.35,1,上市天数),COLORWHITE;
DRAWNUMBER_FIX(1,0.19,0.45,1,股总市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.19,0.55,1,流通市值),COLORWHITE;
DRAWNUMBER_FIX(1,0.2,0.65,1,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.2,0.75,1,人均持股),COLORWHITE;
DRAWTEXT_FIX(品种类型=1,0.23,0.15,1,’沪 深 A 股’),COLORmaGENTA;
DRAWTEXT_FIX(品种类型=2,0.23,0.15,1,’ 中 小 板’),COLORMAGENTA;
DRAWTEXT_FIX(品种类型=3,0.23,0.15,1,’ 创 业 板’),COLORMAGENTA;
DRAWTEXT_FIX(1,0.23,0.35,1,’天’),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.45,1,’亿元’),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.55,1,’亿元’),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.65,1,’人’),COLORCYAN;
DRAWTEXT_FIX(1,0.23,0.75,1,’股’),COLORCYAN;
DRAWTEXT_FIX(1,0.326,0.01,1,’业绩指标:’),COLORRED;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
销售毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
净利润比率:=(FINANCE(30)/FINANCE(20)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
优质资产率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));
现金负债比:=(FINANCE(25)/FINANCE(15));
净利同增率:=FINANCE(43);
DRAWTEXT_FIX(1,0.34,0.15,1,’净资收益率:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.25,1,’销售毛利率:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.35,1,’净利润率 :’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.45,1,’主营利润率:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.55,1,’优质资产率:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.65,1,’现金负债比:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.34,0.75,1,’净利同增率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.4,0.15,1,净资收益率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.25,1,销售毛利率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.35,1,净利润比率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.45,1,主营利润率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.55,1,优质资产率),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.65,1,现金负债比),COLORWHITE;
DRAWNUMBER_FIX(1,0.4,0.75,1,净利同增率),COLORWHITE;
DRAWTEXT_FIX(1,0.498,0.01,1,’财务指标:’),COLORRED;
市净率:=CONst(DYNAINFO(7) / FINANCE(34));
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));
每股收益年:=CONST(FINANCE(33));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
DRAWTEXT_FIX(1,0.51,0.15,1,’市净率 :’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.25,1,’市销率 :’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.35,1,’每股收益季:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.45,1,’每股收益年:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.55,1,’每股现金流:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.65,1,’每股未分配:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.51,0.75,1,’每股公积金:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.57,0.15,1,市净率),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.25,1,市销率),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.35,1,每股收益季),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益年),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.55,1,每股现金流),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.65,1,每股未分配),COLORWHITE;
DRAWNUMBER_FIX(1,0.57,0.75,1,每股公积金),COLORWHITE;
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
DRAWTEXT_FIX(1,0.85,0.01,1,’财务预警:’),COLORRED;
DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,’ ○轻 警○’),COLOR0099FF;
DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,’ ◎无 警◎’),COLORLIGREEN;
LC:=REF(CLOSE,1);
Wrsi:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(Abs(CLOSE-LC),5,1)*100;
获利筹码:=CONST(WINNER(C)*100);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=(IF(SAT>1,1,SAT)*100);
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃:=(WRSI-WR10);
活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));
DRAWTEXT_FIX(1,0.74,0.15,1,STRCAT(STRCAT(‘量能饱和: ‘,CON2STR(量能饱和,2)),’%’)),COLORYELLOW;
DRAWTEXT_FIX(1,0.74,0.35,1,STRCAT(STRCAT(‘活跃度比: ‘,CON2STR(活跃度比,2)),’%’)),COLORYELLOW;
DRAWTEXT_FIX(1,0.74,0.55,1,STRCAT(STRCAT(‘获利筹码: ‘,CON2STR(获利筹码,2)),’%’)),COLORYELLOW;
DRAWRECTREL(970,340,580,270,RGB(150,10,250));
DRAWRECTREL(970,470,580,540,RGB(150,10,250));
DRAWRECTREL(970,670,580,740,RGB(150,10,250));
DRAWRECTREL(970,340,580+CONST(量能饱和*(970-580)/100),270,RGB(0,100,0));
DRAWRECTREL(970,470,580+CONST(活跃度比*(970-580)/100),540,RGB(0,100,0));
DRAWRECTREL(970,670,580+CONST(获利筹码*(970-580)/100),740,RGB(0,100,0));
DRAWTEXT_FIX(1,0.96,0.01,1,’大盘趋势:’),COLORRED;
DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.16,1,’∧∧∧∧’),COLORRED;
DRAWTEXT_FIX( CONST(INDEXC) >sar(4,2,20),0.95,0.11,1,’∧∧∧∧’),COLORRED;
DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.16,1,'∨∨∨∨'),COLORGREEN;
DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.11,1,'∨∨∨∨'),COLORGREEN;
风格:=FGBLOCK;
DRAWTEXT_FIX(1,0.14,0.9,1,’风格:’),COLORYELLOW;
DRAWTEXT_FIX(1,0.9,0.9,1,FGBLOCK),COLORWHITE;

【股池网提醒:此指标公式仅适合于技术研究,不对投资结果负责,股市有风险,投资需谨慎!免费复制代码请先–注册会员-!】

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

申明:股池网是股票软件指标公式、股票池交流学习平台,不开展相关证券业务,同时平台上一切资讯、文章、资料均来自网络收集,不保障实时性和真实性,其版权归原作者所有,如有侵权请时联系我们客服,我们将第一时间删除。由此引起的投资亏损与本站无关。

股池网 其它公式 【通用公式】:通达信规避踩雷指标公式 https://www.g3xs.com/11355.html

发表评论
暂无评论
股池网在线客服

为您解决烦忧 - 您的问题反馈我们也非常重视